Gotek Drive: Disk not ready on EPS 16

HxC Floppy Emulator Ensoniq Keyboards/Samplers support
Post Reply
ghostinthemachine
Posts: 26
Joined: Sat Jun 11, 2016 9:36 am

Gotek Drive: Disk not ready on EPS 16

Post by ghostinthemachine »

Hi,

i have a Gotek drive in my EPS 16, loaded with some 2550kb images. Sometimes the EPS respondes with Disk Drive not ready, if i go to another image on the USB and go back to the original Images it loads one Instrument, if i want to load another it says the same again. And i have to switch to another Image and back to the original...??? Anyone a idea what could be the problem?

Jeff
Site Admin
Posts: 7097
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Gotek Drive: Disk not ready on EPS 16

Post by Jeff »

And what about the normal sized disks ? have you the same problem ?

belzrebuth
Posts: 6
Joined: Tue Jan 07, 2020 9:52 am

Re: Gotek Drive: Disk not ready on EPS 16

Post by belzrebuth »

I have the same exact problem..
Disk drive not ready on a EPS 16+.
Any solution?

Jeff
Site Admin
Posts: 7097
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Gotek Drive: Disk not ready on EPS 16

Post by Jeff »

belzrebuth wrote:
Wed Feb 26, 2020 11:20 am
I have the same exact problem..
Disk drive not ready on a EPS 16+.
Any solution?
Please describe exactly what you have :

- Which emulator are you using ?
- What can you read on the emulator screen without usb / sdcard inserted ?
- What can you read on the emulator screen with the usb / sdcard inserted ?
- Which firmware version is installed ?
- Is the access LED always lit ?
- Which jumpers / switches setting are you using ?

belzrebuth
Posts: 6
Joined: Tue Jan 07, 2020 9:52 am

Re: Gotek Drive: Disk not ready on EPS 16

Post by belzrebuth »

I'm using a gotek with HxC firmware, it's installed correctly no always-on led and I'm able to write/read and format disks.
I think I'm running the latest firmware version as I've got the firmware roughly a month ago..
I'm sorry but I have no idea of the firmware version number..

I think the problem only manifests when I'm trying to access a new disk just after I boot to the OS.

If I wait a bit (5-10 seconds) after I change the disk it works okay.
It may be some delay setting maybe?

Can I restore the firmware setting to its default values?

Jeff
Site Admin
Posts: 7097
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Gotek Drive: Disk not ready on EPS 16

Post by Jeff »

belzrebuth wrote:
Wed Feb 26, 2020 10:53 pm
Can I restore the firmware setting to its default values?
Yes : press the right button at power up.

Regarding the delay :

Press both buttons -> Enter the menu 5 (Auto select delay) and set the lowest value : viewtopic.php?f=33&t=1683#p16457

Post Reply