Can't write from IBM XT Clone to SDcard...

HxC Floppy Emulator on IBM PC and compatible support
Post Reply
Posts: 1
Joined: Tue Dec 22, 2015 2:39 pm

Can't write from IBM XT Clone to SDcard...

Post by giobbi »


I'm using the SD Card emulator with an IBM XT Clone. It worked flawless and I got the XT working, booting from SD Card, formatting the HDD, transferring the system on it and then making many floppy images and transferring all the old software I got from the web to the XT Clone.
Very happy with my SD HxC Emu!!!

But I can't get it working in write mode. I put an emtpy image on the SDcard and tried to copy some files from C: to A:
Apparently, it works... it seems the files are copied on the floppy disk (also the HxC display is showing a writing status), but a simple DIR A: command shows an empty floppy.

Also the Format command on an SDcard image with some files has the same behavior: apparently working, but when you run a DIR A:, the files are still there.

I tried with both 3.5", 720 kb, 80 tracks-2 sides and 5.25", 360 Kb, 40 tracks, 2 sides images:

EDIT -- The 80 tracks image returns a "drive not ready writing on A:" error.

Any idea?


Site Admin
Posts: 7141
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris

Re: Can't write from IBM XT Clone to SDcard...

Post by Jeff »

Jumper/switch setting ? Please share your HFE files.

Post Reply