Firmware Update Error "E01"

HxC Floppy Emulator on Atari ST support
Post Reply
tikidays
Posts: 1
Joined: Thu Jan 25, 2024 7:17 pm

Firmware Update Error "E01"

Post by tikidays »

Hi guys, hope you can help.

I inherited and atari with a GoTek, its running firmware FF-3.37 and it worked with .ST files fine. Its a USB Stick version, and displays "F-F'"on power up with no stick, indicating it has a bootloader installed.

So I attempted to upgrade, and things went wrong.

When I copied over the latest File Selector it asks me to upgrade the firmware. It no longer makes it to the selector if you bypass this message saying "ERROR: Bad Config file version !" , which is odd as this is the one that came with this File Selector.

However loading the firmware for:
- Gotek with 7 segments screen, without rotary.
Generic_Gotek > Standard_Firmware > HxCFEUSB_V5_2_1_2a.UPD
Engaging "Upg" by holding the two buttons down, results in an error with "EO1" displayed on the LCD.

Whats my next step to try?

Thanks in advance!

Post Reply