OLED not working (sometimes) Newest Version

HxC Floppy Emulator on Atari ST support
Post Reply
macsonny
Posts: 8
Joined: Wed Jul 21, 2021 10:46 am

OLED not working (sometimes) Newest Version

Post by macsonny »

Hi All,

AFter 30 years being away I’m back into Atari ST’s having bought an Atari 1040 STFM recently. In the process of recapping and refurbish the machine and close to being finish. I’ve bought a new GoTek and spent a few days working out how to reflash as it’s a new model and has to be reflashed via the USB<->USB cable method. Anyway, now flashed to latest firmware.

I’ve installed a speaker in the GoTek and also the OLED screen. The issue is that the screen has really only worked a few times. I’ve been a bit lucky getting it going with a reset on the two pins on the GoTek and/or a long press on the front buttons on boot. However, I can’t get the screen to work consistently.

I’ve done some reading and it looks like it might be a timing issue and apparently I can fix with a firmware update. Issue is, I have the latest firmware installed. So I’m a bit stumped on what to do next?

Hope someone can help.

Thanks

Sonny

Jeff
Site Admin
Posts: 7638
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: OLED not working (sometimes) Newest Version

Post by Jeff »

What can you read on the Gotek screen without any usb stick connected ?

macsonny
Posts: 8
Joined: Wed Jul 21, 2021 10:46 am

Re: OLED not working (sometimes) Newest Version

Post by macsonny »

Nothing shows on the screen - it's just blank most of the time. When it does work - it works perfectly.

I managed to flash the 3.27 FlashCopy firmware into the unit. I have the newer version with the Artery chipset so it was a little difficult to work out but finally got it flashed.

I have since purchased the firmware from www.hxc2001.com but there isn't a HEX file in the package that I can use to flash my device and I can't work out how to get the boot loader firmware flashed into the device as again - thee is not hex file to load the boot loader via the Artery flashing software.

I'm stuck and need help!

Jeff
Site Admin
Posts: 7638
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: OLED not working (sometimes) Newest Version

Post by Jeff »

I have sent to you the hex and dfu files by email

Jeff
Site Admin
Posts: 7638
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: OLED not working (sometimes) Newest Version

Post by Jeff »

Jeff wrote:
Thu Jul 22, 2021 12:08 am
I have sent to you the hex and dfu files by email
Forwarded 2 more times. Let me know if you have receive it.

macsonny
Posts: 8
Joined: Wed Jul 21, 2021 10:46 am

Re: OLED not working (sometimes) Newest Version

Post by macsonny »

Jeff wrote:
Thu Jul 22, 2021 12:08 am
I have sent to you the hex and dfu files by email
Thank you!

macsonny
Posts: 8
Joined: Wed Jul 21, 2021 10:46 am

Re: OLED not working (sometimes) Newest Version

Post by macsonny »

Jeff wrote:
Thu Jul 22, 2021 12:10 am
Jeff wrote:
Thu Jul 22, 2021 12:08 am
I have sent to you the hex and dfu files by email
Forwarded 2 more times. Let me know if you have receive it.
I have not received anything. Have you got my email from the purchase I made 12 hours ago?

Jeff
Site Admin
Posts: 7638
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: OLED not working (sometimes) Newest Version

Post by Jeff »

macsonny wrote:
Thu Jul 22, 2021 12:23 am
Jeff wrote:
Thu Jul 22, 2021 12:10 am
Jeff wrote:
Thu Jul 22, 2021 12:08 am
I have sent to you the hex and dfu files by email
Forwarded 2 more times. Let me know if you have receive it.
I have not received anything. Have you got my email from the purchase I made 12 hours ago?
Yes.
Probably blocked for some reasons by your ISP. Please send me an email with another address.

macsonny
Posts: 8
Joined: Wed Jul 21, 2021 10:46 am

Re: OLED not working (sometimes) Newest Version

Post by macsonny »


Jeff
Site Admin
Posts: 7638
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: OLED not working (sometimes) Newest Version

Post by Jeff »

macsonny wrote:
Thu Jul 22, 2021 12:28 am
Try macsonski@gmail.com
Done !
(EDIT : Time to sleep for me here... Availabe again in 8 hours... :) )

macsonny
Posts: 8
Joined: Wed Jul 21, 2021 10:46 am

Re: OLED not working (sometimes) Newest Version

Post by macsonny »

Still nothing? Is it caught up in your email queue?

Jeff
Site Admin
Posts: 7638
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: OLED not working (sometimes) Newest Version

Post by Jeff »

macsonny wrote:
Thu Jul 22, 2021 12:39 am
Still nothing? Is it caught up in your email queue?
i don't know...

i have just retried without the attached files.

Post Reply