Unable to boot or access floppy images

Post Reply
xohs
Posts: 10
Joined: Sat Jun 27, 2020 3:18 am

Unable to boot or access floppy images

Post by xohs »

Hi, I have the following setup -

- Gotek device now configured with 3.4.16.4a.
- OLED screen but no 3rd button, so I am using indexed mode.
- Using HXCSDFE.CFG from Config_Files->Indexed_mode. Unmodified in any way, copied straight to the root of the USB stick.
- No other config files present on the drive, just that .CFG and the .HFE or .IMG files.
- No jumpers at all installed on the Gotek drive.
- Connected to a 486 PC, Adaptec 1542CP card's floppy controller.
- With a 2nd physical 1.2MB 5.25" floppy on the chain as B drive.
- BIOS configured for A: = 1.44 B = 1.2.
- Primarily followed the instructions on flashing from this site and also here (minus the CD-ROM mount): http://www.n4vlf.net/gotek.html

This same cabling was working 100% fine with 2 physical floppy drives and with the original Gotek firmware. I can go back to the physical floppy and it works.

The HxC firmware appears to be installed properly. The screen works as expected.

My problem is I can select my DSKA0000.HFE file but it never boots. I have multiple bootable .HFEs (converted from .IMG) that show up but won't boot. I have confirmed that the OLED shows 'disk inserted'. After booting the hard drive to Win95 and trying to access the drive, I see "Not ready reading drive A" on every disk selected. Same result with the original .IMG file instead of .HFE.

Tried multiple USB sticks, formatted with Windows 10's diskpart to make sure the entire drive was clean. Tried FAT16 and FAT32 with the same result.

I don't usually post for help until I've tried everything I can think of and read all of the docs, yet here I am. Any ideas from the community? Is there something specific that needs to happen on the drive or settings to boot or access the disk? Thanks in advance.

Jeff
Site Admin
Posts: 7148
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Unable to boot or access floppy images

Post by Jeff »

xohs wrote:
Sat Jun 27, 2020 5:52 am
- No jumpers at all installed on the Gotek drive.
You need it least one on S0 or S1. Since this is a PC try S1 first.

xohs
Posts: 10
Joined: Sat Jun 27, 2020 3:18 am

Re: Unable to boot or access floppy images

Post by xohs »

Thank you for the reply. I had seen another thread that suggested removing jumpers because they function differently with HxC firmware.

Tried a jumper on S1, which was on by default when I received the device. Same behavior - no boot. I then powered off, moved to S0, retried, and same behavior. In both cases Windows 95 shows not ready reading drive A upon any access across all of my images.

I see the OLED screen and images upon bootup. I see the initial "seek" for the device upon initial boot (green light turns on, screen shows RA). Just does not boot any of the images. Have tried multiple boot disks, from that DOS 6.22 disk distributed by Microsoft to image files from bootdisk.com (extracted from the .exes they provide). Both with .IMG and .HFE format.

Is there a known good test .HFE or .IMG file that I can try to eliminate any potential that it's the image? Perhaps a FreeDOS boot disk?

I was reading the docs for the diagnostic firmware and not entirely following how the test works. If that's another suggestion as a next step let me know, I'll read up on the other threads before asking more questions. Thank you.

Jeff
Site Admin
Posts: 7148
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Unable to boot or access floppy images

Post by Jeff »

Are you able to read the images from the emulator under windows or dos ?

xohs
Posts: 10
Joined: Sat Jun 27, 2020 3:18 am

Re: Unable to boot or access floppy images

Post by xohs »

Yes, for example here's the DOS 6.22 disk 1.
dos622.PNG
dos622.PNG (28.91 KiB) Viewed 127 times

Jeff
Site Admin
Posts: 7148
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Unable to boot or access floppy images

Post by Jeff »

No, i mean : Can you read the read the "floppy emulator" under windows or dos ?

xohs
Posts: 10
Joined: Sat Jun 27, 2020 3:18 am

Re: Unable to boot or access floppy images

Post by xohs »

Thanks, and not sure I understand your question.

If you are asking if the Gotek device is accessible under Windows/DOS, the answer is no. After booting the hard drive to Win95 and trying to access the drive, I see "Not ready reading drive A" on every disk selected. Same result with the original .IMG file instead of .HFE.

Jeff
Site Admin
Posts: 7148
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Unable to boot or access floppy images

Post by Jeff »

xohs wrote:
Tue Jun 30, 2020 7:04 pm
Thanks, and not sure I understand your question.

If you are asking if the Gotek device is accessible under Windows/DOS, the answer is no. After booting the hard drive to Win95 and trying to access the drive, I see "Not ready reading drive A" on every disk selected. Same result with the original .IMG file instead of .HFE.
Ok. Is the gotek's green LED liting when you try to access the gotek ? What can you read on the gotek screen ?

xohs
Posts: 10
Joined: Sat Jun 27, 2020 3:18 am

Re: Unable to boot or access floppy images

Post by xohs »

I was still having a problem so I figured let's buy a real HxC from Lotarek and give that a shot. Surprisingly I'm having the exact same problem. To be clear I abandoned the Gotek and now have a brand new HxC installed.

Recap of my Setup
  • 486 PC
  • Adaptec 1542CP (with floppy controller)
  • No floppy controller anywhere else in the system (ie no motherboard floppy exists)
  • Cable correctly connected to controller with pin 1 to red stripe side
  • First position of the cable goes to physical 5.25" drive
  • Cable then has a 'twist' as expected
  • 3.5" drive was attached to the end of the cable and works 100%, boots, can read disks, etc.
  • BIOS set for 3.5" drive A, 5.25" drive B, with a boot order of A,C
So that all works as expected. Now we replace the 3.5" physical drive with the HxC emulator, no other changes to the system.
  • New Sandisk 32GB SD card, erased in win10 with diskpart and reformatted as FAT32 (standard format, not quick)
  • Placed HXCFE_V1_8_2_40.upd on card, inserted, flashed successfully. Shows 1.8.2.40 briefly before asking for an HXCSDFE.CFG file
Here's a Youtube video of my flashing process: https://youtu.be/qabbLS44tsc
  • Next, I removed the .upd file, copied the HXCSDFE.CFG to the root of the card (photo attached of settings)
  • Copied 2 .HFE files, as converted from .IMG In the HxC Windows software
Now I tested as follows (jumper/switch settings):
  • Tested with all HxC physical switches off except ID2 on (drive A)
  • Tested with all HxC switches off except ID1 on (drive a with twisted floppy ribbon)
Both of the above did not work, system will not boot or read the disks. Another Youtube video showing this: https://youtu.be/nRX_lFeaIoE

The above video was taken when the ID1 jumper was on, the rest off (for A: drive only, with twisted floppy ribbon).

Finally, just to make absolutely certain that my cabling is not problematic, I went back to the physical drive and tested. Here's a video of that process showing DOS 6.22 booting successfully: https://youtu.be/ZzickLnIJtY

I'm thinking this is one of a few things. Either the HXCSDFE.CFG file is incorrect or my .HFE images are problematic. Any thoughts or input you can provide would be very helpful, thank you.
Attachments
HXCSDFE.CFG
HXCSDFE.CFG
SDHCCFG.PNG (33.48 KiB) Viewed 109 times

Jeff
Site Admin
Posts: 7148
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Unable to boot or access floppy images

Post by Jeff »

Share your hfe files.

xohs
Posts: 10
Joined: Sat Jun 27, 2020 3:18 am

Re: Unable to boot or access floppy images

Post by xohs »

Update -

I found this post: viewtopic.php?p=7467#p7467

You had a DOS .HFE bootable disk in there so I downloaded it and tried it out. Boots perfectly on the system, so this is telling me I am having a problem with my .HFE files.

xohs
Posts: 10
Joined: Sat Jun 27, 2020 3:18 am

Re: Unable to boot or access floppy images

Post by xohs »

Interesting, a large part of my problem is that HxCFloppyEmulator can't read Microsoft's .IMG format. I'm using their DOS 6.22 distribution from MSDN/Visual Studio, as available for subscriber download even today.

They provide a series of .IMG files. Even tried opening with v2.4.1.9 and it just shows Load Error! Read file error!

If I open the same. IMG file in UltraISO and export it out as an .IMA file (just file->save as, no changes), HxCFloppyEmulator can read that and properly convert it into a .HFE disk. I just tried this and was able to boot DOS no problem.

Would you like me to send you the original .IMA files? I wouldn't offer if this wasn't "real" Microsoft-distributed software, I imagine others will attempt to do the same thing.

Jeff
Site Admin
Posts: 7148
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Unable to boot or access floppy images

Post by Jeff »

Again i need your HFE/IMG/IMA files to be able to diagnose the issue. Normal IMG are of course working with the hxc tool (i use them almost every day)
So please share the images.

xohs
Posts: 10
Joined: Sat Jun 27, 2020 3:18 am

Re: Unable to boot or access floppy images

Post by xohs »

Here are the images -
https://filebin.net/9uucbyozyaym51tx/en ... t=xcamu2sy

That's the original DOS 6.22 distro from Microsoft, I didn't make the images. But the 144UPG1, 2, and 3 images don't convert successfully with the hxc tool. Download link expires 1 week from now.

Jeff
Site Admin
Posts: 7148
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Unable to boot or access floppy images

Post by Jeff »

xohs wrote:
Sat Jul 11, 2020 12:13 am
Here are the images -
https://filebin.net/9uucbyozyaym51tx/en ... t=xcamu2sy

That's the original DOS 6.22 distro from Microsoft, I didn't make the images. But the 144UPG1, 2, and 3 images don't convert successfully with the hxc tool. Download link expires 1 week from now.
Why the archive is in a .exe ?

Post Reply