MPC60II gotek/HxC settings and configuration

HxC Floppy Emulator Akai Keyboards/Samplers support
Post Reply
Silverfish
Posts: 4
Joined: Tue Oct 10, 2017 8:03 am

MPC60II gotek/HxC settings and configuration

Post by Silverfish »

Hi all,

I recently installed the HxC bootloader onto an older 2-digit Gotek (model SFRM72-TU100K), but I can't seem to get the MPC60II to recognize anything that's happening on the drive. When I power up the MPC, the drive shows "hc", then allows me to select a disk image via the two buttons. However, the MPC says there is no disk in the drive, error code FF80.

Which direction should the data cable go? What are the correct jumper settings? Am I using the wrong firmware? Could it be the config file?

Thanks so much for your help!

Jeff
Site Admin
Posts: 7140
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: MPC60II gotek/HxC settings and configuration

Post by Jeff »

The jumper must be on S0.
If the green led is always on, try to reverse the floppy ribbon.

Silverfish
Posts: 4
Joined: Tue Oct 10, 2017 8:03 am

Re: MPC60II gotek/HxC settings and configuration

Post by Silverfish »

Funny. I could have sworn I tried this particular configuration, but apparently not.

It's working fine now. Thank you for your help!

Silverfish
Posts: 4
Joined: Tue Oct 10, 2017 8:03 am

Re: MPC60II gotek/HxC settings and configuration

Post by Silverfish »

After some time, I'm revisiting my MPC60 and I've discovered that the gotek/hxc drive is not working as I thought. I've been unable to generate a working blank .hfe file, but I found a file that I was able to load from. When I go to save to the floppy image, the machine starts the process, but then gives an error message: "This disk is either bad, not formatted or formatted by a different device. Format it or use a different disk. Error code: FF04"

What gives? I'm using the latest firmware file and the indexed mode config file. Thanks for your help.

Silverfish
Posts: 4
Joined: Tue Oct 10, 2017 8:03 am

Re: MPC60II gotek/HxC settings and configuration

Post by Silverfish »

Okay, it gets weirder.

I created a blank image, formatted, then created a short sample, and was able to save it to the floppy image. Then, I created a much larger sample, but when I tried to save it, I got the error message.

Could this be an issue with something else in the machine? Power supply?

Jeff
Site Admin
Posts: 7140
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: MPC60II gotek/HxC settings and configuration

Post by Jeff »

Your usb stick is probably too slow at writing. Try another one.

Please note that if you have the last firmware, you can now directly use the Akai IMG files without converting them into HFE. The main benefice is that the write speed is much faster, and then this should solve your issue too without changing the usb stick.

Anyway to have a proper diagnostic, please send me your failed HFE to hxc2001 at hxc2001.com

Post Reply