Akai S950

HxC Floppy Emulator Akai Keyboards/Samplers support
Post Reply
Posts: 6
Joined: Sat Nov 09, 2019 1:48 pm

Re: Akai S950

Post by andyfox »

Hello, finally I was able to find a solution for the AKAI S950 and that error. Problem was indeed the voltage of the HxC floppy. But it was very difficult to find it. Infact, at first, when booting, voltage was 5v. Then, when loading from SD Card a sound, the voltage was getting lower. So that was why I got "OOPPPS!!!! ... " message in the middle of the loading.
The power supply was recapped with new capacitors from the technician, however the problem was not solved. Maybe my power supply is indeed that old, and should be replaced, or rebuilt from scratch.
So we basically added a dedicated power supply providing 5v.. just for the HxC floppy.
I know this maybe is not the clean and best solution wanted, but I have been using the S950 since some weeks and it appears to work.
I must say I also replaced the display with a color LCD display, a new one. That's maybe why the Power Supply was working too hard to give power to all machine components is getting harder for it.
Thanks for helping me ! I will keep you posted if there are future evolutions and the problems come back.
I personally hope no! :D


Posts: 2
Joined: Thu Dec 16, 2021 7:13 pm

Re: Akai S950

Post by littlejackal »

I have a similar issue but I don't see any unnatural voltages so unfortunately I don't have that option to me.

I have a GoTek with the new chip-shortage substituted Artery and implemented HxCFEUSB_V4_0_53a.UPD. When I throw this onto the GoTek everything seems to work in the end, but I see the following behaviour:

- Boot S950 with USB or without, doesn't seem to matter. If a USB is in the S950 doesn't seem to autoload programs at startup so presumably the USB is not being read properly at this time
- Hit Disk button
- Mounted floppy shows UNFM% so clearly image has not been read properly
- Hit Play button, then Disk button again and UNFM% now properly shows the proper used percentage.

After this it seems to load and save as expected. If I change floppy images the problem manifests itself all over again. At first it shows UNFM% but then after hitting play and disk again the newly mounted disk is now properly readable.

I haven't encountered an OOPS error yet after the "second disk push" and after this is done the disk access seems to be fairly reliable, though I have only been running this for a few hours.

I'm using the provided S950 floppy images and the Gotek is in indexed mode.

I'm happy to just say "ok this is how it works" since it's not a huge issue (unless there are OOPS errors that are going to pop up eventually, I guess) but I'm not sure now whether troubleshooting would reveal this is a beta firmware update given there is a new chip in play, whether the HFE files are somehow bad (unlikely, seems to work after that the first initial hiccup), or whether there's other problems at play.

Site Admin
Posts: 7758
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris

Re: Akai S950

Post by Jeff »

This appears to be an interface mode setting issue. Which HFE files are you using exactly ?
Can you try to clear/reset all the settings and set the S950 interface mode in the embedded menu ?
https://hxc2001.com/docs/gotek-floppy-e ... tings.html

And which Artery Gotek are you using exactly ?

Posts: 2
Joined: Thu Dec 16, 2021 7:13 pm

Re: Akai S950

Post by littlejackal »

I think that worked. At first I loaded the 4053a firmware in the "new sfrkc30 firmware" folder but that was causing some issues with the firmware corrupting (3 LCDs go blank, no activity until I re-flash) when I changed any settings from the config menu, but then I flashed 4201a from the WIP folder and it seems to be much happier letting me set these settings. Set 1->0c, 2->0f, 5->01 to appeal to my preferences and interface and it seems to be much more reliable from the get-go. Haven't had an issue yet, crossing my fingers.

I've got one of the new shortage-replacement chips, KBU7-4 I think, similar or identical to what's in the sfrkc30 folder. I think that's my board but I'd have to disassemble the 950 to check and it seems to be working great right now :)

Thanks for the advice!

Post Reply