Emulator I with No Boot problem

HxC Floppy Emulator E-mu Emulator I & II support
Post Reply
Posts: 4
Joined: Tue Feb 27, 2018 12:34 pm

Emulator I with No Boot problem

Post by TheProf »


I am in the invidious position of servicing an Emulator I which wont boot. It did slightly less than this before I started, but I wont bore you with the details. The original SA400 drive seemed to be defunct so I decided to install my stock Rev E Lotharek SD drive to see if I could get it to run. This drive has f/w version and is the single drive on a non-twisted cable set to ID/3. The first attempt to boot resulted in nothing at all. I have tried both the boot loaders/OS from both the quick floppy pack and EMPX.net. After monitoring the drive cable with a scope it became apparent that the /STEP strobe wasn’t present. Change the PIO in the Emulator I and now the drive goes ‘tick’ ‘tick’ very rapidly when first switched on, the display sets ‘RA’ attributes but nothing else. The drive light (like on the SA400) remains on. Here is a list of signals on the interface. Note the index line /INDEX this seems to be the only activity apart from data on a couple of other lines. The /INDEX pulses are constant and seem to strobe at about 200mS intervals.

34 - /READY - low
32 - /SIDE1 - high
30 - /RDATA - data
28 - /WPROT - high
26 - /TRK000 - low
24 - x
22 - x - data (!)
20 - /STEP - high
18 - /DIR - high
16 - /MTRON - low
14 - /DS2 - low
12 - /DS1 - low
10 - /DS0 - low
8 - IDX - Strobe (see above)
6 - x
4 - x
2 - /CHG - low

Any ideas what should happen next on a working system? BTW I have changed the SIO/2 as well!


Site Admin
Posts: 7910
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris

Re: Emulator I with No Boot problem

Post by Jeff »

which images are you using ?

Posts: 4
Joined: Tue Feb 27, 2018 12:34 pm

Re: Emulator I with No Boot problem

Post by TheProf »

Hi Jeff,

I am using EMU_I.hfe which is in the Quick Floppy Image pack on the HxC2001 project pages. I have also tried version 3.11 and 3.07 of the Emulator I OS provided by EMXP.net. There’s is different in that you need a disk geometry file, extension .EMUFD with the image. I think, no doubt, is that I have a h/w problem with the disk controller. Before I started I had no /STEP strobe which I fixed by replacing the Z80 PIO. The Emulator has a Z80 PIO/SIO arrangement rather than a custom device from, say, WDC. I guess what I am after is inside knowledge on what happens next. The drive rapidly ticks at me when first switched on. The Emulator is supposed to do this, 5 tracks in and then out to track 0. This line is low so the drive should be ready to read. Additionally the index pulses are now appearing, but nothing else. Really the question is what should happen next? I am guessing it should start stepping the head again, but that’s where it ends.

Many thanks for your help,

Post Reply