"Autoboot" / File selector mode working except for HXCFEMNG

HxC Floppy Emulator on Amiga support
Firepawa
Posts: 15
Joined: Sun Apr 22, 2018 1:48 pm

Re: "Autoboot" / File selector mode working except for HXCFEMNG

Post by Firepawa » Thu May 10, 2018 11:13 am

Inside the beast:
WP_20180510_10_49_05_Pro.jpg
Power Computing enclosure board
WP_20180510_10_49_05_Pro.jpg (213.24 KiB) Viewed 840 times
WP_20180510_10_48_15_Pro.jpg
Power Computing enclosure board
WP_20180510_10_48_15_Pro.jpg (159.59 KiB) Viewed 840 times
WP_20180510_10_47_55_Pro.jpg
Gotek board
WP_20180510_10_47_55_Pro.jpg (191.75 KiB) Viewed 840 times
I should add that I made a custom short floppy cable to fit inside the enclosure but I tried with the original cable and another full size floppy cable with exactly the same result.

Jeff
Site Admin
Posts: 5746
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: "Autoboot" / File selector mode working except for HXCFEMNG

Post by Jeff » Fri May 11, 2018 10:59 am

Why you don't have connected the VSS/GND gotek power supply wire ?

Firepawa
Posts: 15
Joined: Sun Apr 22, 2018 1:48 pm

Re: "Autoboot" / File selector mode working except for HXCFEMNG

Post by Firepawa » Fri May 11, 2018 2:21 pm

Yes this is also weird in this enclosure.
Only one wire (power) is connected to the power connector...
This is how it was when I opened the enclosure the first time.
I assumed the ground was going through the other connector.

The wire was directly soldered to the drive power connector so I replaced it with a removable connection.

As the Gotek drive powered on correctly I didn't think too much of this...

Jeff
Site Admin
Posts: 5746
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: "Autoboot" / File selector mode working except for HXCFEMNG

Post by Jeff » Tue May 15, 2018 9:03 am

What is this IC on the picture ? An PAL or something else ?

Firepawa
Posts: 15
Joined: Sun Apr 22, 2018 1:48 pm

Re: "Autoboot" / File selector mode working except for HXCFEMNG

Post by Firepawa » Tue May 15, 2018 11:16 am

After searching a bit I found this forum thread which discusses various Power Computing enclosures with a few pictures:
http://eab.abime.net/showthread.php?t=64016
Here is a zoomed picture of the IC without the sticker:
PC880SUB.jpg
PC880SUB.jpg (71.66 KiB) Viewed 784 times
Is this readable enough for you or should I reopen the enclosure and remove the sticker ?

PascalDe73
Posts: 2
Joined: Sun Jan 14, 2018 5:39 pm

Re: "Autoboot" / File selector mode working except for HXCFEMNG

Post by PascalDe73 » Wed May 16, 2018 9:47 pm

Hello,
At first I tried to use my gotek in a box external, I had the same problem with the same box (same look with plastic top). It is totally incompatible neither with a firmware version HXC or even CORTEX. I finally abandoned this external box that has only one wire for the power of the floppy drive. In summary look for another external box with a 4-wire power supply and you will not have any problems. I currently use 4 gotek HXC in 4 boxes of different brands but all are with 4-wire power ... So before buying on ebay another external box especially ask to see pictures of the inside of the case to see the number of supply wires and especially if the cable 34 pins is reversible because in some cases it is necessary to return also the cable 34 pins...

Pascal De :D

Firepawa
Posts: 15
Joined: Sun Apr 22, 2018 1:48 pm

Re: "Autoboot" / File selector mode working except for HXCFEMNG

Post by Firepawa » Thu May 17, 2018 1:19 pm

Thanks for your reply.
Another confirmation that there is something strange about this enclosure.
As I stated before this not a big issue for me as I will eventually install an OLED screen and not use HXCFEMNG.

However I think it is interesting for the HXC firmware dev (Jeff ?) to at least try to debug this issue as it could come up again with another enclosure or on another system. And who knows maybe a software fix is possible...

Jeff
Site Admin
Posts: 5746
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: "Autoboot" / File selector mode working except for HXCFEMNG

Post by Jeff » Thu May 17, 2018 6:09 pm

Firepawa wrote:
Thu May 17, 2018 1:19 pm
However I think it is interesting for the HXC firmware dev (Jeff ?) to at least try to debug this issue as it could come up again with another enclosure or on another system. And who knows maybe a software fix is possible...
The problem is that i don't have this setup and encloser to debug it properly...

Firepawa
Posts: 15
Joined: Sun Apr 22, 2018 1:48 pm

Re: "Autoboot" / File selector mode working except for HXCFEMNG

Post by Firepawa » Fri May 18, 2018 1:52 pm

Jeff wrote:
Thu May 17, 2018 6:09 pm
The problem is that i don't have this setup and encloser to debug it properly...
Well at least you (and everyone else here) know that there may be a problem with those Power Computing enclosures...

If you want one for testing, I just found a very cheap one on ebay:
https://www.ebay.fr/itm/lecteur-de-disq ... SwPYpa-BQv

Jeff
Site Admin
Posts: 5746
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: "Autoboot" / File selector mode working except for HXCFEMNG

Post by Jeff » Fri May 18, 2018 8:10 pm

Firepawa wrote:
Fri May 18, 2018 1:52 pm
Jeff wrote:
Thu May 17, 2018 6:09 pm
The problem is that i don't have this setup and encloser to debug it properly...
Well at least you (and everyone else here) know that there may be a problem with those Power Computing enclosures...
they are maybe designed to be compatible with pc style floppy drive. this is maybe the purpose of the internal ic. In this case you maybe need to change the hxc interface mode to be compatible with the case. (this is pure speculation)

Firepawa
Posts: 15
Joined: Sun Apr 22, 2018 1:48 pm

Re: "Autoboot" / File selector mode working except for HXCFEMNG

Post by Firepawa » Mon May 21, 2018 6:06 pm

I got back to it and made a few more tests:

1- Set Interface settings to PC HD : Drive not detected by the Amiga OS and not detected by HXCFEMNG.
2- Amiga cold reboot
3- Set Interface settings to PC SD : Drive detected by Amiga OS (but no disc change). Not detected by HXCFEMNG.
4- Amiga cold reboot
5- Set Interface settings to Atari ST : Same as PC SD.

Then I was discouraged so I restored a backup I made of my previous HXCSDFE.CFG, made a warm reboot of the Amiga and when it was fully started I inserted the USB key.
It was working as before and so I started HXCFEMNG just to make sure... and it worked ! I was able to browse the USB key, modify an entry and perform a Save & Reboot.
After the reboot the floppy was there working as before but HXCFEMNG did not detect the drive again... I tried many reboots (cold and warm), I recopied again my HXCSDFE.CFG backup but no cigar... I also retried booting in Atari ST mode, perform a warm reboot and then inserting the USB key with the backup HXCSDFE.CFG but same result.
I was not able to make HXCSDFEMNG work again. I don't know if it was something I did or a timing issue or if it was just luck but it worked once.

The original floppy drive is an EPSON SMD-300:
well it says SMD-300 on the big sticker but SMD-380 on the back...
Attachments
WP_20180521_17_29_23_Pro.jpg
WP_20180521_17_29_23_Pro.jpg (196.86 KiB) Viewed 695 times
WP_20180521_17_30_18_Pro.jpg
WP_20180521_17_30_18_Pro.jpg (203.65 KiB) Viewed 695 times

Firepawa
Posts: 15
Joined: Sun Apr 22, 2018 1:48 pm

Re: "Autoboot" / File selector mode working except for HXCFEMNG

Post by Firepawa » Fri Aug 10, 2018 1:07 pm

I finally installed an OLED screen and a rotary encoder:
WP_20180810_12_44_34_Pro.jpg
WP_20180810_12_44_34_Pro.jpg (147.72 KiB) Viewed 351 times
I can confirm that this Power Computing enclosure works fine with this configuration.
In the end everything seems to work fine with this enclosure except HXCFEMNG on the Amiga.

I hope this information can be useful to someone.

Post Reply