Problème d'écriture avec un cpc

HxC Floppy Emulator on Amstrad CPC support
Post Reply
axys
Posts: 4
Joined: Sat Jun 02, 2012 5:34 pm

Problème d'écriture avec un cpc

Post by axys » Sat Jul 02, 2016 12:42 pm

Salut Jeff,

Je possède plusieurs cpc (crtc différents)... Avec l'un d'eux (crtc 4), le HxC fonctionne très bien.
Le HxC est à jour avec les dernières versions (firmware et disk manager).

Par contre avec un autre cpc (crtc 1), il semble y avoir un problème au moment d'écrire sur la sdcard... Voici les tests que j'ai effectué :
- je branche le HxC sur le cpc 4 (crtc 4), avec le manager je rempli quelques slots... je sauve, reboot, et fait defiler les slots sans probleme.. Je peux lancer les demos/jeux..
- je debranche le HxC et je le branche sur l'autre cpc (crtc 1)... Pareil, je peux selectionner et et lancer les demos..
- je lance le manager, change quelques hfe... sauve (tout parait bien se passer), reboot...
et là c'est le drame, le HxC me demande sans arrêt "choose a file"...
Si je lance le manager, je peux voir que certains slots sont vides (ça semble alétoire)... J'ai beau essayer de remplir à nouveau les slots rien n'y fait...

Si je rebranche sur le cpc 4, même comportement "choose a file".. Je lance le manager, rempli les slots, sauve... et à partir de là tout fonctionne...

Avez-vous une idée de ce qui pourrait faire que le cpc (crtc 1) n'arrive pas à écrire correctement ?

Jeff
Site Admin
Posts: 5706
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Problème d'écriture avec un cpc

Post by Jeff » Sun Jul 03, 2016 12:19 am

a priori c'est l'alimentation qui doit etre au dessus de 5V.

axys
Posts: 4
Joined: Sat Jun 02, 2012 5:34 pm

Re: Problème d'écriture avec un cpc

Post by axys » Sun Jul 10, 2016 12:41 pm

Je viens de recevoir une alimentation 5v 3A... :)

Ce n'est pas mieux.. mais le comportement a changé... lorsque que je charge le disk manager, le HxC fait un décompte (il ne le faisait pas avant) puis charge le manager..
Une fois chargé, 9 fois sur 10 il affiche un message d'erreur.. en remuant la nappe au niveau du connecteur du cpc ça passe de temps en temps...
À partir de là même problème qu'avant, quand je sauve la selection, au reboot j'ai droit à un "choose a flie"...

J'ai testé avec un 3ème CPC, pas de problème... Donc c'est bien un problème avec ce cpc en particulier :(

J'ai bien nettoyé le connecteur du cpc... Testé avec 2 nappes différentes...
Je ne vois pas trop quoi tester d'autre...

Post Reply