Unable to image 1.44M floppy

HxC Floppy Emulator on IBM PC and compatible support
Post Reply
snhirsch
Posts: 160
Joined: Tue Dec 08, 2015 1:42 am

Unable to image 1.44M floppy

Post by snhirsch » Sat Dec 12, 2015 10:14 pm

I am having no success trying to image a known-good 1.44M floppy. ImageDisk reads it without incident, but when I convert to HFE and try to start that, the computer complains "Drive Not Ready" at boot. The emulator is otherwise working correctly: If I create a blank 1.44M image using HxCFloppyEmulator I'm able to format that image on the computer, copy system and files to it and boot it.

I also tried converting the .IMD file to a sector image using the ImageDisk IMDU utility, then used HxCFloppyEmulator to read that and export HFE. No luck, same failure.

Any suggestions appreciated.

Update: I've tried a number of other methods to create an HFE from the diskette: HxC floppy direct load from physical media and SAMdisk copy to dsk --> HFE. Same problem: "Drive Not Ready".

Is this supposed to work? Is this forum active, or should I be asking in a different venue?

Jeff
Site Admin
Posts: 6303
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Unable to image 1.44M floppy

Post by Jeff » Mon Dec 14, 2015 9:07 pm

Jumper setting problem ? Floppy ribbon connection problem ? Gotek not in indexed mode ?
What say the gotek ?!

snhirsch
Posts: 160
Joined: Tue Dec 08, 2015 1:42 am

Re: Unable to image 1.44M floppy

Post by snhirsch » Mon Dec 14, 2015 9:28 pm

Jeff wrote:Jumper setting problem ? Floppy ribbon connection problem ? Gotek not in indexed mode ?
What say the gotek ?!
Jumper is correct. No ribbon problem. Gotek is in indexed mode.

This exact setup works fine with an image that I format on the Gotek while attached to the machine. The problem is that I'm unable to use an image that's either converted from ImageDisk OR read from physical floppy using the HxCFloppyEmulator program.

It is not something as basic as what you imply.

Post Reply