I just cannot get it working?

HxC Floppy Emulator on Atari ST support
Post Reply
FatRakoon
Posts: 1
Joined: Fri May 18, 2018 1:27 am

I just cannot get it working?

Post by FatRakoon » Fri May 18, 2018 1:36 am

Admittely, I have lost patience with it.

I have the USB floppy emulator, v3.0.6.6a
No matter what I try, I have simply failed entirely, to get it working, or to get it to do anything other than crash my Atari.
I have tried various firmwares, and bugger knows whats on it now.
It never sees the Floppy, assumes there is no disk, or simply crashes the Machine entirely?

Can anyone give me a run-down on what needs to be done, starting with Flashing it, and then what files it needs to work as a floppydisk.

I have a TT030 and a Falcon060 ( CT63 ) if that makes ANY difference?

On and off, I have tried dozens of varations and files and whatevers, but I have simply failed to get it working at all.

Thanks.

Jeff
Site Admin
Posts: 5714
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: I just cannot get it working?

Post by Jeff » Fri May 18, 2018 7:44 am

FatRakoon wrote:
Fri May 18, 2018 1:36 am
I have the USB floppy emulator, v3.0.6.6a
i suppose you have a gotek drive ? First please update this prehistoric version to the latest current version :


http://hxc2001.com/download/floppy_driv ... rmware.zip

http://hxc2001.com/download/floppy_driv ... _notes.txt

USB HxC Floppy Emulator Update procedure :

:arrow: Copy the new firmware file (*.upd) to a FAT32/FAT16/FAT12 USB flash device.
:arrow: Insert the USB Stick into the emulator and press both buttons.
:arrow: Power up the device and keep the buttons pressed during at least 2 seconds.
:arrow: Wait some seconds... its done !

Bootstrap error codes:

Error 1 : (blink 1 time and 2 seconds pause cycle) No entry point (->no software flashed)
Error 2 : (blink 2 time and 2 seconds pause cycle) USB init error.
Error 3 : (blink 3 time and 2 seconds pause cycle) FAT error.
Error 4 : (blink 4 time and 2 seconds pause cycle) UPD File not found!
Error 5 : (blink 5 time and 2 seconds pause cycle) Bad UPD File header! (bad file)
Error 6 : (blink 6 time and 2 seconds pause cycle) Bad data crc! (file corrupted)
Error 7 : (blink 7 time and 2 seconds pause cycle) Bad data size!
Error 8 : (blink 8 time and 2 seconds pause cycle) Write error (STM32 flash error)

Jeff / HxC2001
And what is crashing exactly ? The file selector ?

tzok
Posts: 69
Joined: Sat Jan 27, 2018 2:52 pm

Re: I just cannot get it working?

Post by tzok » Fri May 25, 2018 3:41 pm

Are you sure you are connection the ribbon cable correctly? Connecting it upside-down may damage the Gotek drive! In the Falcon, contrary to the ST models, you don't need to flip the cable/mount the unit upside down. It will look wrong, but that is the correct position.

Post Reply