Problem with OLED and Gotek

HxC Floppy Emulator on Amiga support
dougal
Posts: 31
Joined: Tue Nov 28, 2017 11:37 am

Re: Problem with OLED and Gotek

Post by dougal » Tue Nov 28, 2017 4:08 pm

Jeff wrote:
Tue Nov 28, 2017 4:04 pm
For the other issues i know, this is normal.
Ok thanks. I look forward to the fix for the OLED. So for now I reverted to the firmware v 3.0.33.12a so I can use the games.

So to re-cap, basically when switched on no OLED display UNLESS either I do an update or else if I hit RESET jumper on the Gotek board and then it works fine until switch off (but reboots are no problem it remains working)

Jeff
Site Admin
Posts: 6464
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Problem with OLED and Gotek

Post by Jeff » Tue Nov 28, 2017 4:21 pm


dougal
Posts: 31
Joined: Tue Nov 28, 2017 11:37 am

Re: Problem with OLED and Gotek

Post by dougal » Tue Nov 28, 2017 5:12 pm

Jeff wrote:
Tue Nov 28, 2017 4:21 pm
Another try :
http://hxc2001.com/vrac/HxCUSBFE3.UPD
Sorry but still not working. I saw the power up delay now has 2.5, i tried that and i tried 1 and i tried none. But still same

Jeff
Site Admin
Posts: 6464
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Problem with OLED and Gotek

Post by Jeff » Tue Nov 28, 2017 6:22 pm

dougal wrote:
Tue Nov 28, 2017 5:12 pm
Jeff wrote:
Tue Nov 28, 2017 4:21 pm
Another try :
http://hxc2001.com/vrac/HxCUSBFE3.UPD
Sorry but still not working. I saw the power up delay now has 2.5, i tried that and i tried 1 and i tried none. But still same
Well then this will be hard for me to solve this is since i don't have this exact same screen.
i will check that the new delay feature works correctly this evening but i recommend you this exact screen : https://www.ebay.com/itm/302110929185
Anyway If you want to spend more times on this i can send you a firmware with the debug on the serial port. Let me know if you are ok or not with this (you need to have the serial usb adapter).

dougal
Posts: 31
Joined: Tue Nov 28, 2017 11:37 am

Re: Problem with OLED and Gotek

Post by dougal » Tue Nov 28, 2017 6:36 pm

Jeff wrote:
Tue Nov 28, 2017 6:22 pm
dougal wrote:
Tue Nov 28, 2017 5:12 pm
Jeff wrote:
Tue Nov 28, 2017 4:21 pm
Another try :
http://hxc2001.com/vrac/HxCUSBFE3.UPD
Sorry but still not working. I saw the power up delay now has 2.5, i tried that and i tried 1 and i tried none. But still same
Well then this will be hard for me to solve this is since i don't have this exact same screen.
i will check that the new delay feature works correctly this evening but i recommend you this exact screen : https://www.ebay.com/itm/302110929185
Anyway If you want to spend more times on this i can send you a firmware with the debug on the serial port. Let me know if you are ok or not with this (you need to have the serial usb adapter).
I have the usb to serial adapter which came with the Gotek and which I had used to put the original Cortex FW on when I got it. I probably used it again to put the HxC firmware too but its been a while so I forgot. I cannot remember the whole process though.

Jeff
Site Admin
Posts: 6464
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Problem with OLED and Gotek

Post by Jeff » Wed Nov 29, 2017 12:27 am

ADF file support regression fixed and power delay fixed too :

http://hxc2001.com/vrac/HxCUSBFE.UPD

dougal
Posts: 31
Joined: Tue Nov 28, 2017 11:37 am

Re: Problem with OLED and Gotek

Post by dougal » Wed Nov 29, 2017 7:19 am

Jeff wrote:
Wed Nov 29, 2017 12:27 am
ADF file support regression fixed and power delay fixed too :

http://hxc2001.com/vrac/HxCUSBFE.UPD
Thanks. I tried it. ADF working fine but the oled still nope unless i reset or initiate upgrade :(

I have ordered the oled you recommended but in the meantime if you manage to fix the issue it would be great.

Jeff
Site Admin
Posts: 6464
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Problem with OLED and Gotek

Post by Jeff » Wed Nov 29, 2017 8:23 am

New version (v3.0.34.7a) : Slow down oled init function :
http://hxc2001.com/vrac/HxCUSBFE.UPD

Jeff
Site Admin
Posts: 6464
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Problem with OLED and Gotek

Post by Jeff » Wed Nov 29, 2017 8:56 am

Btw where did you get this screen exactly ?

dougal
Posts: 31
Joined: Tue Nov 28, 2017 11:37 am

Re: Problem with OLED and Gotek

Post by dougal » Wed Nov 29, 2017 10:50 am

This is the one I’m using
Attachments
9A6C811F-1886-4E16-A01B-3E1FF5177298.jpeg
9A6C811F-1886-4E16-A01B-3E1FF5177298.jpeg (73.46 KiB) Viewed 2461 times

dougal
Posts: 31
Joined: Tue Nov 28, 2017 11:37 am

Re: Problem with OLED and Gotek

Post by dougal » Wed Nov 29, 2017 2:43 pm

Jeff wrote:
Wed Nov 29, 2017 8:23 am
New version (v3.0.34.7a) : Slow down oled init function :
http://hxc2001.com/vrac/HxCUSBFE.UPD
Sorry but still same. Tried 250, 500, 750, 1s and 2.5s on power delay but same thing.

Jeff
Site Admin
Posts: 6464
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Problem with OLED and Gotek

Post by Jeff » Wed Nov 29, 2017 3:36 pm

dougal wrote:
Wed Nov 29, 2017 10:50 am
This is the one I’m using
Could you put the exact same link you used to buy it ? Your picture previous picture and this one don't match.

dougal
Posts: 31
Joined: Tue Nov 28, 2017 11:37 am

Re: Problem with OLED and Gotek

Post by dougal » Wed Nov 29, 2017 3:42 pm

Jeff wrote:
Wed Nov 29, 2017 3:36 pm
dougal wrote:
Wed Nov 29, 2017 10:50 am
This is the one I’m using
Could you put the exact same link you used to buy it ? Your picture previous picture and this one don't match.
https://www.ebay.co.uk/itm/0-91-IIC-I2C ... 2749.l2649

This one - Its from my eBay account

dougal
Posts: 31
Joined: Tue Nov 28, 2017 11:37 am

Re: Problem with OLED and Gotek

Post by dougal » Wed Nov 29, 2017 11:35 pm

I know from the pic it looks exactly like the one you told me to get (which I bought since you told me) but that link is of the one I currently have now. Its the actual eBay item I had bought in October.

Jeff
Site Admin
Posts: 6464
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Problem with OLED and Gotek

Post by Jeff » Thu Nov 30, 2017 12:08 am

dougal wrote:
Wed Nov 29, 2017 11:35 pm
I know from the pic it looks exactly like the one you told me to get (which I bought since you told me) but that link is of the one I currently have now. Its the actual eBay item I had bought in October.
i see "www.diymore.cc" printed on yours screen + it have a different parts annotations. This sound odd.

Post Reply