SD HxC not found in Workbench as DF1

HxC Floppy Emulator on Amiga support
Post Reply
Silkworm
Posts: 4
Joined: Sun Jun 25, 2017 5:50 pm

SD HxC not found in Workbench as DF1

Post by Silkworm » Sun Jun 25, 2017 6:22 pm

hello guys,

I bought a HXC SD floppy emulator some time ago for my CPC.

Now I want to use it for my Amiga 500.

So I also bought this adapter to connect my HxC to the disk port: http://amigastore.eu/en/440-amiga-exter ... er-m1.html
I set the jumpers to the DF1 position but when I start Workbench from internal DF0, no external drive appears. I'm using Workbench1.3 because I have no other version on disks to boot from.

I'dont know what I'm doing wrong, so I would appreciate any advice.

(When I disconnect the internal drive the HxC works as DF0 on the disk port with adapter.)

Does the SD card needs some special files to be recognised as DF1 or does Workbench also finds the drive with a missing SD card?
Attachments
pic3.jpg
pic3.jpg (48.16 KiB) Viewed 469 times
pic2.jpg
pic2.jpg (51.95 KiB) Viewed 469 times
pic1.jpg
pic1.jpg (66.17 KiB) Viewed 469 times

Silkworm
Posts: 4
Joined: Sun Jun 25, 2017 5:50 pm

Re: SD HxC not found in Workbench as DF1

Post by Silkworm » Wed Jul 05, 2017 10:31 am

hello again,

I tried to solve my problem by using this boot selector:
http://www.ebay.de/itm/New-Boot-Selecto ... Sw4DJYig7q

Unfortunately it doesnt change anything, I have still the same problems as described above. Somehow the sd hxc is not really recognized as DF0.

If I want to autoboot from the external port set as DF0 the file selector displays the following message:

ERROR: Write - No Index Timeout ! (state 0)

What can I do to solve the problem?
Attachments
pic4.jpg
pic4.jpg (44.17 KiB) Viewed 421 times

Jeff
Site Admin
Posts: 4842
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: SD HxC not found in Workbench as DF1

Post by Jeff » Wed Jul 05, 2017 11:53 am

The problem is for sure the adapter you are using. Can you post its schematic here ?

Jeff
Site Admin
Posts: 4842
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: SD HxC not found in Workbench as DF1

Post by Jeff » Wed Jul 05, 2017 12:00 pm

Jeff wrote:The problem is for sure the adapter you are using. Can you post its schematic here ?
Well, interesting comment :

http://amigastore.eu/en/440-amiga-exter ... er-m1.html

Code: Select all

matburton
17/04/17
Not very compatible with the HxC
The ribbon cable soldered to this adapter is backwards (red stripe wrong side) and the notch on it prevents you from plugging it into the HxC in reverse. To use this with the HxC you'll have to file the notch off the ribbon cable.

Next-up it seems the adapter always connects the device as DF0, which means you can't use the HxC to emulate

two drives externally. I couldn't get it to work at any rate. Even when daisy chained to another mechanical external drive the HxC appears as DF2 to the Amiga but must have it's jumpers set to DF0.

I'd give this 4/5 stars if the product listing had listing these details rather that just say it was HxC compatible. Read Less
So this is an hardwired adapter. You need to set the jumper to ID0-A on the HxC... if i have well understood the comment.
a schematic will be better anyway.

Silkworm
Posts: 4
Joined: Sun Jun 25, 2017 5:50 pm

Re: SD HxC not found in Workbench as DF1

Post by Silkworm » Thu Jul 06, 2017 6:58 pm

thx so much for your help Jeff!! :) :)

I changed the jumper to ID0 position and the HxC is now recognised as DF1.

I even managed to copy files from the HxC to real disks. Most games are running now without any problems.

Unfortunately I have no schematic of the adapter.

What adapter do you recommend or fits best for the sd hxc?

Thx again, great job!

Silkworm
Posts: 4
Joined: Sun Jun 25, 2017 5:50 pm

Re: SD HxC not found in Workbench as DF1

Post by Silkworm » Sun Jul 09, 2017 2:02 pm

hello again,

I am not able to use a second drive on the HxC.

1)
Bootselector:
DF0=internal drive
DF1=HxC

HxC Jumper:
A: ID0 position
B: ID1 position


no virtual second drive is recognised in WB -> only HxC as DF1

2)
Bootselector:
DF0=HxC
DF1=internal drive

HxC Jumper:
A: ID0 position
B: ID1 position


no virtual second drive is recognised in WB -> only HxC as DF0

What can I do to get a second drive on the Hxc??

This configuration would be nice:
HxC: DF0 & DF1
internal drive: DF2

any ideas?

Jeff
Site Admin
Posts: 4842
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: SD HxC not found in Workbench as DF1

Post by Jeff » Mon Jul 10, 2017 7:08 am

As i said the problem is the adapter. You need its schematic to modify it and reroute the DS1/DS2/DS3 signals. Only one signal is used actually, so only one drive can be addressed. Please ask the schematic to the seller or the guy who designed it. I don't have is here, so i can't do any reverse here...

matburton
Posts: 7
Joined: Sun Jan 29, 2017 11:44 pm

Re: SD HxC not found in Workbench as DF1

Post by matburton » Mon Sep 11, 2017 9:47 pm

Hey Silkworm,

I posted that review on Amigastore :lol: sounds like you've gone through the same woes that I did.

After that I did the following:
  • Found this schematic (at the bottom of the page)
  • Asked someone on ebay to make one like that but with SEL3 also wired-up (had to file-off the tab again)
  • Installed a DF0 selector switch
The up-shot of the first two is that I can now use the HxC as both DF1 and DF2 externally (or DF2 and DF3 daisy chained from a mechanical drive). If you do the same be sure to jumper the HxC to DS0 and DS1 regardless of the setup because of the way the SEL lines are daisy chained (that also applies if you decide to install a DF0 selector).

If you do install a DF0 selector then the HxC will work as both DF0 and DF2 with the above jumper settings (DF1 gets missed-out because of the way the DF0 selector works)

Lastly having SEL3 connected did nothing :lol: I only did that in case the HxC could actually emulate a third drive not mentioned in the manual or in case support for a third drive was added in the future (probably unlikely, I'm guessing it's a hardware limitation)

Post Reply