2.42" 128x64 I2C OLED screen

solarmon
Posts: 81
Joined: Tue Feb 26, 2019 9:38 am

Re: 2.42" 128x64 I2C OLED screen

Post by solarmon » Mon Mar 11, 2019 8:46 pm

Tried the new test firmware, with connection to JB pin. I still only get the version splash screen, stable with no corruption.

Jeff
Site Admin
Posts: 6786
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: 2.42" 128x64 I2C OLED screen

Post by Jeff » Mon Mar 11, 2019 9:04 pm

solarmon wrote:
Mon Mar 11, 2019 8:46 pm
Tried the new test firmware, with connection to JB pin. I still only get the version splash screen, stable with no corruption.
Ok then there is a floating signal somewhere or there is a power supply issue. the gotek 3.3V ldo has maybe some problem to power it.
Have you tried to power the screen on the 5V ?

solarmon
Posts: 81
Joined: Tue Feb 26, 2019 9:38 am

Re: 2.42" 128x64 I2C OLED screen

Post by solarmon » Mon Mar 11, 2019 9:31 pm

Jeff wrote:
Mon Mar 11, 2019 9:04 pm
Ok then there is a floating signal somewhere or there is a power supply issue. the gotek 3.3V ldo has maybe some problem to power it.
Have you tried to power the screen on the 5V ?
For testing I have been mainly using the 5V from a USB port on my laptop to power the Gotek. I've also tried it connected to my Amiga 1200 5V floppy drive power port.

I have also tried powering the OLED screen via the 5V PIN on the Gotek.

All have same issue - stuck at the version splash screen.

I was able to get same Gotek unit and screen, with same 5v power supplies, connecting RES directly to one of the 3.3v pins.

Jeff
Site Admin
Posts: 6786
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: 2.42" 128x64 I2C OLED screen

Post by Jeff » Mon Mar 11, 2019 9:52 pm

Contrast reduced and dynamic contrast change disabled :

https://hxc2001.com/vrac/HxCUSBFE5.UPD

(keep the RES - JB wire for the moment).

solarmon
Posts: 81
Joined: Tue Feb 26, 2019 9:38 am

Re: 2.42" 128x64 I2C OLED screen

Post by solarmon » Mon Mar 11, 2019 11:03 pm

Jeff wrote:
Mon Mar 11, 2019 9:52 pm
Contrast reduced and dynamic contrast change disabled :

https://hxc2001.com/vrac/HxCUSBFE5.UPD

(keep the RES - JB wire for the moment).
OK, looks like we are getting somewhere! Buttons, rotary encoder and scrolling all seems to work too.

But...under very specific circumstances:

It only works when I power the Gotek with my laptop USB port (I'm using a USB serial cable with dupont header sockets, as per previously) - and only when voltage supplied is under 4v. AND I need to power the OLED screen off a 5V pin. It does not seem to get past the splash screen when trying to power the OLED screen with 3.3V.

It does not seem to matter which 3.3v pin I connect RES to.

Connecting to the Amiga 5v floppy power connector does not seem to work. Connecting it to a USB powerbank (using same serial cable), which is showing 4.85v, does not work.


Image

Jeff
Site Admin
Posts: 6786
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: 2.42" 128x64 I2C OLED screen

Post by Jeff » Mon Mar 11, 2019 11:08 pm

Ok interesting.

Try this one :

i2c gpios set in low speed mode :

https://hxc2001.com/vrac/HxCUSBFE6.UPD

Jeff
Site Admin
Posts: 6786
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: 2.42" 128x64 I2C OLED screen

Post by Jeff » Mon Mar 11, 2019 11:10 pm

Btw these specific circumstances also works with the previous firmware (HxCUSBFE4.UPD) ?

Jeff
Site Admin
Posts: 6786
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: 2.42" 128x64 I2C OLED screen

Post by Jeff » Mon Mar 11, 2019 11:21 pm

Jeff wrote:
Mon Mar 11, 2019 11:08 pm
Ok interesting.

Try this one :

i2c gpios set in low speed mode :

https://hxc2001.com/vrac/HxCUSBFE6.UPD
Try this one instead (a fix...) :

https://hxc2001.com/vrac/HxCUSBFE7.UPD

solarmon
Posts: 81
Joined: Tue Feb 26, 2019 9:38 am

Re: 2.42" 128x64 I2C OLED screen

Post by solarmon » Mon Mar 11, 2019 11:28 pm

Jeff wrote:
Mon Mar 11, 2019 11:10 pm
Btw these specific circumstances also works with the previous firmware (HxCUSBFE4.UPD) ?
Yes, assuming I have flashed it correctly (it is hard to tell since the version shown is the same) - it also seems to work under these 'circumstances' with HxCUSBFE4.UPD.

I don't know whether it is the USB port that is supply the under 4v voltage - or whether it is the Gotek and/or OLED screen pulling down to under 4v when it is working fully.

I'll try HxCUSBFE7.UPD now.

Jeff
Site Admin
Posts: 6786
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: 2.42" 128x64 I2C OLED screen

Post by Jeff » Tue Mar 12, 2019 12:01 am

i2c bus speed up to 400khz :
https://hxc2001.com/vrac/HxCUSBFE8.UPD

solarmon
Posts: 81
Joined: Tue Feb 26, 2019 9:38 am

Re: 2.42" 128x64 I2C OLED screen

Post by solarmon » Tue Mar 12, 2019 12:05 am

Tried HxCUSBFE7.UPD and I can't seem to get to to work at all now, not even going back to HxCUSBFE5.UPD :cry:

I don't know whether the USB cable under voltage is a sympton or the cause, but here are my observations of it:

USB voltage:

* 4v+ = Stuck/freeze on splash screen
* 3.8v - 4v = Stuck/freeze on file selection screen
* 3.6v - 3.8v = file selection screen working - scrolling, left/right buttons, rotary encoder, switch button, etc.

With my 128x32 OLED screen (no RES pin) it works flawlessly - even with HxCUSBFE7.UPD, screen powered with 3.3v or 5v. USB voltage does not change, matter, or is applicable.

I will try to get a proper PoR (Power on Reset) RC circuit connected up to see if that makes a difference - just need to order the resistors and capacitors.

Jeff
Site Admin
Posts: 6786
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: 2.42" 128x64 I2C OLED screen

Post by Jeff » Tue Mar 12, 2019 12:18 am

solarmon wrote:
Tue Mar 12, 2019 12:05 am
Tried HxCUSBFE7.UPD and I can't seem to get to to work at all now, not even going back to HxCUSBFE5.UPD :cry:
if you can't make work the HxCUSBFE5.UPD fw i think that a signal is floating somewhere... What about the "DC" pin ?

i am also wondering how much current this screen is drawing. i see a buck boost circuit on the back. it is maybe interesting to add a 22uF capacitor on the input voltage.
solarmon wrote:
Tue Mar 12, 2019 12:05 am
I will try to get a proper PoR (Power on Reset) RC circuit connected up to see if that makes a difference - just need to order the resistors and capacitors.
I don't think this is the problem here : the JB output is doing this job.

i will post some more firmware to test.

solarmon
Posts: 81
Joined: Tue Feb 26, 2019 9:38 am

Re: 2.42" 128x64 I2C OLED screen

Post by solarmon » Tue Mar 12, 2019 12:20 am

Jeff wrote:
Tue Mar 12, 2019 12:01 am
i2c bus speed up to 400khz :
https://hxc2001.com/vrac/HxCUSBFE8.UPD
Tried HxCUSBFE8.UPD, doesn't seem to make a differrence. Mostly stuck on version splash screen. Occasionally stuck on on file select screen.

Again, my 128x32 0.96" screen works flawlessly, even with HxCUSBFE8.UPD.

Jeff
Site Admin
Posts: 6786
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: 2.42" 128x64 I2C OLED screen

Post by Jeff » Tue Mar 12, 2019 12:30 am

Slow down the init procedure, and reduce a little more the contrast :

https://hxc2001.com/vrac/HxCUSBFE9.UPD

solarmon
Posts: 81
Joined: Tue Feb 26, 2019 9:38 am

Re: 2.42" 128x64 I2C OLED screen

Post by solarmon » Tue Mar 12, 2019 12:36 am

Jeff wrote:
Tue Mar 12, 2019 12:18 am
i think that a signal is floating somewhere... What about the "DC" pin ?
I had left DC floating - sorry, I thought I had mentioned this, probably/possibly only in the EAB forum post. :oops:

I had not needed to connect this when using - so I didn't consider this.

So I connected DC to a GND pin - the JB one.....and....it's working, perfectly!! :D

I am so sorry that I did not mention that DC is floating. I've wasted a lot of your time. :cry:

Post Reply