GOTEK EMULATORF WITH EMAX HD SFTWRE REV. 3.2

Post Reply
Timbrre
Posts: 6
Joined: Fri Feb 15, 2019 12:26 am

GOTEK EMULATORF WITH EMAX HD SFTWRE REV. 3.2

Post by Timbrre » Fri Feb 15, 2019 9:58 pm

Hi hope all is well,I am new to this forum and yes I have tried everything except for the one or more things that I will be told to try by the members on this forum who know more than myself,have been there,have done that :),I bought a Gotek emulator about 3 years ago but never attempted to install it until now,when I connect it to the emax it displays HxC, does this mean that the HxC software was already installed when I purchased it(the purchase was made on ebay) for this reason I have not attempted to update the firmware although I have purchased a TTL to USB adapter,of the floppy discs that I have, due there age none of them seem to be fully functional but I was able to determine that my software revision is 3.2, I went online and watched a few video's to try and figure out what I was not doing correctly and this is how I learned of this site,so far I have followed the instructions from this link viewtopic.php?f=15&t=1412 (How to make a Bootable Emax SD card Step By Step) I also have read a lot but still can't figure out what I am not doing correctly,the jumper on my Gotek is set to s0. There's a lable on top of my Gotek which reads download the manual and FW udpdate at hxc2001.COM bootloader uprade by www.deftaudio.ru
So currently with the Gotek attacthed to the emax and the fat 32 formatted 4G Kingston USB Plugged in and powered on it displays HxC, the emax goes through it's diagnostics then shows the message loading software. If I hold the two buttons on the Gotek and repower the emax the Gotek displays 004 with or without the USB plugged in. I have did so much reading I am now reading confused :? LOL :lol: , I would greatly appreciate help to get the Gotek working on my emax,what should I do,what am not doing,what am I not doing correctly. So far the only good thing that has come out of me not being able to figure things out is the discovery of this site and all the resources that are available for the emax and that's really cool.
I have attached a screen capture of the files that I sent to my USB stick and the SDCard HxC Floppy Emulator Settings that I used if this will help.

Jeff
Site Admin
Posts: 6463
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: GOTEK EMULATORF WITH EMAX HD SFTWRE REV. 3.2

Post by Jeff » Fri Feb 15, 2019 11:13 pm

Yes you have an HxC Firmware.
First update it :
https://hxc2001.com/download/floppy_dri ... rmware.zip

Copy the upd file to the stick and follow the update procedure :
viewtopic.php?f=33&t=1683&p=11486#p16456

Then copy the indexed cfg file and some emax images :
https://hxc2001.com/download/floppy_dri ... Images.zip

Timbrre
Posts: 6
Joined: Fri Feb 15, 2019 12:26 am

Re: GOTEK EMULATORF WITH EMAX HD SFTWRE REV. 3.2

Post by Timbrre » Fri Feb 15, 2019 11:54 pm

Wow you responded very fast :o :D , I will follow your suggestions and let you know the results,thanks very much for your time.

Timbrre
Posts: 6
Joined: Fri Feb 15, 2019 12:26 am

Re: GOTEK EMULATORF WITH EMAX HD SFTWRE REV. 3.2

Post by Timbrre » Sat Feb 16, 2019 3:15 am

Hi, I updated the firmware as you suggested and copied the contents of the quick install package for the emax to my USB stick. The Gotek now shows nor on the display which I think stands for normal but the emax stays on the loading software screen after diagnostics are complete. I copied the indexed_mode config file from the HXCFEUSB_HFE_beta_firmware package to the USB and tried it but the Gotek flashed 000 twice followed by Err. According to the update documentation I think it was this bootstrap error code...Error 2 : (blink 2 time and 2 seconds pause cycle) USB init error. I reinstalled the the config file from the quick install package to the USB stick and the Gotek then displayed nor again but my emax remains at the loading software screen but at least the Gotek is doing more now than it has for the last four days all thanks to you,what should I do next :idea: and also I am grateful to you for your help.

Jeff
Site Admin
Posts: 6463
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: GOTEK EMULATORF WITH EMAX HD SFTWRE REV. 3.2

Post by Jeff » Sat Feb 16, 2019 9:38 am

Timbrre wrote:
Sat Feb 16, 2019 3:15 am
but the Gotek flashed 000 twice followed by Err. According to the update documentation I think it was this bootstrap error code...Error 2 : (blink 2 time and 2 seconds pause cycle) USB init error
No, you just forgot to add a file image or forgot to rename it DSKA0000.HFE,DSKA0001.HFE,DSKA0002.HFE.
This is needed in indexed mode.

Timbrre
Posts: 6
Joined: Fri Feb 15, 2019 12:26 am

Re: GOTEK EMULATORF WITH EMAX HD SFTWRE REV. 3.2

Post by Timbrre » Sat Feb 16, 2019 3:27 pm

Good morning Jeff hope all is well with you. Ok then,so I wiil copy the indexed config file back to the USB,rename the file DSKA0000. HFE,DSKA0001.HFE,DSKAOOO2.HFE and give it a go later in the day however later last night I tried again but this time I waited about a minute and then pressed the left button on the Gotek,the emax screen showed loading bank followed by the message wrong software. This morning I began reading about this error message on the forum and see where you explain the difficulties with the emax hd because of the four different operating systems, In reading I recall that you stated of the four you consider the latter two to be irrelevant ,I will go back and read that again,my question is which operating system do you suggest for the emax hd also I am searching the posts to avoid asking questions that you have probably already answered many times before.

Timbrre
Posts: 6
Joined: Fri Feb 15, 2019 12:26 am

Re: GOTEK EMULATORF WITH EMAX HD SFTWRE REV. 3.2

Post by Timbrre » Sat Feb 16, 2019 3:41 pm

Hi Jeff, I went back and read the information about the latter two Emax operating systems being irrelevant I thought that was your post but it was the post of another member my apologies for that.

Timbrre
Posts: 6
Joined: Fri Feb 15, 2019 12:26 am

Re: GOTEK EMULATORF WITH EMAX HD SFTWRE REV. 3.2

Post by Timbrre » Sat Feb 16, 2019 11:58 pm

Hi hope all is well,I copied the indexed config file to the usb and renamed the files as you suggested,the Gotek/emax now work together all thanks to you. Now the Gotek scrolls from 000 to 002 and the emax allows me to select different presets from it's control panel, I haven't counted to see how many though but now it seems that my key bed is not working because when I press the keys I hear no sound but if I play one of the sequencer demos that emax has I hear the demos so I know that the sound output is good,I was also able to adjust the volume with the slider,all of the other buttons and menu's are working fine just no sound when I press any of the keys. If you or any of the forum members have anymore suggestions or ideas that will help me with this new problem it is appreciated in the meantime I will try to solve this keyboard issue if I do I will post it here.

Post Reply