I2C display not working

Post Reply
alchemist
Posts: 31
Joined: Wed Nov 29, 2017 9:48 pm
Location: Belgium

I2C display not working

Post by alchemist » Thu Jan 04, 2018 11:56 am

Hi, and happy new year!

To replace the 2 digits 7-segments display, I am trying to install a IIC display (this one). It's a 128x32 OLED SSD1306 device, with ID=0x3C

I can use it with an Arduino, with the Adafruit sample code, on 3.3V and 5V, but it keeps blank when connected on the Gotek.
I tried to connect pull-up resistors with the same result, and connecting to the 5V connector.

I tried with and without .CFG files (removing the indexed mode .CFG with a normal .CFG), and upgraded to HXCFEUSB_V3_1_1_0a.UPD

What could be wrong?

Kind regards,
Xavier Miller.
Kind Regards,
Xavier Miller

Jeff
Site Admin
Posts: 5810
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: I2C display not working

Post by Jeff » Thu Jan 04, 2018 1:23 pm

What is printed on the PCB ? Please share a picture.

as recommended the one working properly is this one :
https://www.ebay.com/itm/302110929185

alchemist
Posts: 31
Joined: Wed Nov 29, 2017 9:48 pm
Location: Belgium

Re: I2C display not working

Post by alchemist » Thu Jan 04, 2018 1:25 pm

The Gotek PCB or the I2C display ?
Kind Regards,
Xavier Miller

Jeff
Site Admin
Posts: 5810
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: I2C display not working

Post by Jeff » Thu Jan 04, 2018 1:25 pm

alchemist wrote:
Thu Jan 04, 2018 1:25 pm
The Gotek PCB or the I2C display ?
The display or course.

alchemist
Posts: 31
Joined: Wed Nov 29, 2017 9:48 pm
Location: Belgium

Re: I2C display not working

Post by alchemist » Thu Jan 04, 2018 1:26 pm

OK, I send it tonight :)
Kind Regards,
Xavier Miller

Jeff
Site Admin
Posts: 5810
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: I2C display not working

Post by Jeff » Thu Jan 04, 2018 1:27 pm

is the "ID 3C" I2C address ?

Jeff
Site Admin
Posts: 5810
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: I2C display not working

Post by Jeff » Thu Jan 04, 2018 1:28 pm

is it a "diymore.cc" screen ?

alchemist
Posts: 31
Joined: Wed Nov 29, 2017 9:48 pm
Location: Belgium

Re: I2C display not working

Post by alchemist » Thu Jan 04, 2018 1:30 pm

Jeff wrote:
Thu Jan 04, 2018 1:27 pm
is the "ID 3C" I2C address ?
Yes
Jeff wrote:
Thu Jan 04, 2018 1:28 pm
is it a "diymore.cc" screen ?
Yes
Kind Regards,
Xavier Miller

Jeff
Site Admin
Posts: 5810
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: I2C display not working

Post by Jeff » Thu Jan 04, 2018 1:35 pm

alchemist wrote:
Thu Jan 04, 2018 1:30 pm
Jeff wrote:
Thu Jan 04, 2018 1:28 pm
is it a "diymore.cc" screen ?
Yes
this is the root cause of the problem.
Try to connect the screen and attempt an update firmware with the latest firmware version (even if already done). The screen should work after the update. then remove the usb stick, enter the config menu. press both buttons and set the screen init delay to the max value. exit properly the menu.

alchemist
Posts: 31
Joined: Wed Nov 29, 2017 9:48 pm
Location: Belgium

Re: I2C display not working

Post by alchemist » Thu Jan 04, 2018 1:39 pm

OK, I will try it!

Thanks for your high quality support!
Kind Regards,
Xavier Miller

Jeff
Site Admin
Posts: 5810
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: I2C display not working

Post by Jeff » Thu Jan 04, 2018 1:49 pm

alchemist wrote:
Thu Jan 04, 2018 1:39 pm
OK, I will try it!

Thanks for your high quality support!
FYI here is another user with the same screen and the same issue... :
http://torlus.com/floppy/forum/viewtopi ... e&start=45
the problem was "mostly" solved thanks to the delay option. For some reasons these "diymore" screens need lots of time after the power up to be initialized... the firmware option allows you to add some extra delay for the screen init, and the firmware update trick give some time to the screen when you have not yet set this option...

alchemist
Posts: 31
Joined: Wed Nov 29, 2017 9:48 pm
Location: Belgium

Re: I2C display not working

Post by alchemist » Thu Jan 04, 2018 2:05 pm

Yeah, I also have that initialization delay issue with the Arduino. If this is too annoying, I will get the recommended screen.
Kind Regards,
Xavier Miller

Jeff
Site Admin
Posts: 5810
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: I2C display not working

Post by Jeff » Thu Jan 04, 2018 2:07 pm

alchemist wrote:
Thu Jan 04, 2018 2:05 pm
Yeah, I also have that initialization delay issue with the Arduino. If this is too annoying, I will get the recommended screen.
Very interesting. Thanks for confirmation that you got the issue in a totally different context ! (i mean outside the HxC/Gotek context).

alchemist
Posts: 31
Joined: Wed Nov 29, 2017 9:48 pm
Location: Belgium

Re: I2C display not working

Post by alchemist » Thu Jan 04, 2018 2:19 pm

BTW the ebay item 302110929185 is currently out of stock (I2C models)
Kind Regards,
Xavier Miller

alchemist
Posts: 31
Joined: Wed Nov 29, 2017 9:48 pm
Location: Belgium

Re: I2C display not working

Post by alchemist » Thu Jan 04, 2018 10:03 pm

Hi,

The display is always blank. I will order the recommended one. Do you want this bad sample for your laboratory, as poisoned gift?
Kind Regards,
Xavier Miller

Post Reply