Gotek problem stuck OLED SSD1306 screen / Solved

Post Reply
PtrO
Posts: 2
Joined: Wed Dec 13, 2017 7:12 pm

Gotek problem stuck OLED SSD1306 screen / Solved

Post by PtrO » Wed Dec 13, 2017 7:59 pm

Since I played around with the internal configurations settings (the middle button) my OLED SSD1306 screen (128x64) suddenly remains uninitialised.
Is there a way to reset/resolve this ?

Continue reading for details and more.

It was perfectly working and even better with firmware version "HXCFEUSB_V3_1_0_4a.UPD" but then for one magic reason I decided to played around with the diy added "select" middle-button. Happy as newborn to press buttons and select screens......
After I've set some display-setting to 21 characters en pressed NEXT, things went bad.
The OLED screen froze and I was no longer able to exit the screen and the rest thereafter is a train-wreck story of trial an errors.

To summarize, I've already tried the following
  • - RST (reset pins)
  • - Re-inserted vice-versa the LED screen
  • - Tried multiple versions of HXCSDFE.CFG files which have zero effect on my OLED frozen screen
  • - Upgraded back & forth to firmware versions before de OLED was supported (perhaps It might have reset internal flash things).
  • - Using a clean USB stick confirm to me that the problem is probably within the Flash-memory of the Gote, somewhere Jeff's documentation indicates that several settings are saved there.
Note: The OLED screen lights-up and is still perfectly capable for handling I2C as have tested & verified with my BusPirate analyser. The display-driver connection of the JP7 connector is also OK and have no connection problems. The problem lies how the OLED is addressed after I've changed the settings. It seems to me that the OLED is somehow initially addressed by I22@Gotek but unfortunately never properly cleared.

Alternatively, but difficult for me to grasp..... is the bl;indly press the correct sequence of buttons that will reset/clear the stored flash contents. But..... this will be a shot in the dark as I cannot recollect the sequence of menus.... etc...etc nor I doubt if this is working at all without a detected "screen".

Info: The emulator itself since version V3_0_33_12a is a piece of beautiful :P workmanship. As of this version my Akai-S01 sampler now also can/do/read/write and even format HD floppies ( all in S950HD mode) . This HD/speed requires however a fast USB stick to get it working properly and I had to cut pin-2 of the floppy connector towards the Aaka-S01 bus which otherwise would wrongly signalled the S01 for density. The Akai S01, oldjunk, tries to write at HD speed and simply rereads if the action was OK.

I guess that the internal "flash-save" is not/never properly resetting its screen parameters from/to the LCD/OLED settings.
I see the (inside) red-led flashing once, probably turning on the OLED and then things go silent. If required I can do some I2C analysis

Image
Note: I glued the select white-dot button on the gotek itself. The ugly red-tumple-switch was used to (internally) inverse (using an LS7401 TTL circuit) and control the floppy "ready-pin-34" signal. The Akai seems to listen - in a strange way - to this pin to check if the device is busy/operating in HD mode. This all was part (of a longer story) to get things to work. Teh SSD itaself was a SPI version whoich I cpnverted to i2C and added a simple reset-circuit using a diode-RC timer. The SSD1306 OLED is - and was before a changed screen settings, perfectly operating using pulled-up SDA/SCL and 3.3V power.

To resume, my greatest compliments for the wonderfull development and thanks in advance for (re)solutions.

Kind Regards2all and CU
Peter

Added 14dec17 00u08 : Did some additonal logic analyzer measurements on i2c level.
When the HXC is powered on with OLED connected, I observe the following I2C communication ([ = startbit, ]=stopbit) that it generates/address 37 times [0x78+0x00-] followed by continuous loop... operating "[0x38-[][0x80-[][0x08-[][0x00-[]". Not sure if this caused by a faulty clock or a misfired datasequence.
FYI: the SSD1306 OLED is (normally) addressed on 0x78(0x3C W) and shoudl be feeded by an initialisation sequence to get is operating. In the past this was the case until I messed with the internal menu.
Last edited by PtrO on Thu Dec 14, 2017 10:36 am, edited 2 times in total.
Always check for more work...... even if not required. :lol:

Jeff
Site Admin
Posts: 5810
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Gotek problem stuck OLED SSD1306 screen

Post by Jeff » Thu Dec 14, 2017 12:06 am

With the latest firmwares to clear/ignore internal settings : Press "up" button at power up.

for the pin : you don't have to cut them. you have to just change the interface mode into the internal menu.

PtrO
Posts: 2
Joined: Wed Dec 13, 2017 7:12 pm

Re: Gotek problem stuck OLED SSD1306 screen

Post by PtrO » Thu Dec 14, 2017 1:15 am

How simple live can be.......... things works......... now. Merci profondement :mrgreen:
I did cut the pin in the past before I was able to get it working on my Akai S01.
Always check for more work...... even if not required. :lol:

Post Reply