HxC Floppy Drive Emulator

HxC Floppy Drive Emulator general information and news
It is currently Fri Apr 28, 2017 8:02 pm

All times are UTC + 2 hours




Post new topic Reply to topic  [ 16 posts ]  Go to page 1, 2  Next
Author Message
PostPosted: Sun Aug 14, 2011 11:47 pm 
Offline

Joined: Sun Aug 14, 2011 9:41 pm
Posts: 11
Hi guys,

After some false starts, I feel I'm close to getting the emulator working with the MPC60/II.

Lessons learned:
• The floppy drive power connecter has a nub for slotting into the floppy drive's connector. This had to be dremeled off in order for the floppy power connector to fit properly.
• Likewise, the ribbon cable has a nub intended to show the proper way to insert the cable. This also needed to be removed in order for the emulator to work properly.
• <sheepishly> Always make sure you're not laying your pcbs down on a conductive surface.

I have attempted to create a blank disk image with the HXC software (running XP in VirtualBox on my Macbook). Using the s950 disk image suggestions as a guideline:

Track type: MFM
Number of tracks: 80
Sectors per track: 5
Two sides floppy
Sector ID start: 1
RPM: 300
Sector size: 1024
Bitrate: 250000
GAP3 length: 50
Interleave: 1
Skew: 0
Total Sector: 800
Total Size: 819200

I created 1 empty disk image using the above formula, one empty image created with the HXC software's 720kb DSDD FAT12 setting, and 2 different cfg files for testing: one IBM PC 720kb, and one generic shugart. Thus far, when I attempt to format a disk using any combination of the above I get the following error from the MPC:

"This disk is unusable since a defect was found in the area reserved for the file directory. Please insert another disk and try again. [Error code: ff04]


Top
 Profile  
 
PostPosted: Mon Aug 15, 2011 12:18 am 
Offline
Site Admin

Joined: Fri Oct 20, 2006 12:12 am
Posts: 4530
Location: Paris
jchiet wrote:
Hi guys,

After some false starts, I feel I'm close to getting the emulator working with the MPC60/II.

Lessons learned:
• The floppy drive power connecter has a nub for slotting into the floppy drive's connector. This had to be dremeled off in order for the floppy power connector to fit properly.
• Likewise, the ribbon cable has a nub intended to show the proper way to insert the cable. This also needed to be removed in order for the emulator to work properly.
• <sheepishly> Always make sure you're not laying your pcbs down on a conductive surface.

I have attempted to create a blank disk image with the HXC software (running XP in VirtualBox on my Macbook). Using the s950 disk image suggestions as a guideline:

Track type: MFM
Number of tracks: 80
Sectors per track: 5
Two sides floppy
Sector ID start: 1
RPM: 300
Sector size: 1024
Bitrate: 250000
GAP3 length: 50
Interleave: 1
Skew: 0
Total Sector: 800
Total Size: 819200

I created 1 empty disk image using the above formula, one empty image created with the HXC software's 720kb DSDD FAT12 setting, and 2 different cfg files for testing: one IBM PC 720kb, and one generic shugart. Thus far, when I attempt to format a disk using any combination of the above I get the following error from the MPC:

"This disk is unusable since a defect was found in the area reserved for the file directory. Please insert another disk and try again. [Error code: ff04]


Can you try to dump a MPC60 floppy disk first ?


Top
 Profile  
 
PostPosted: Mon Aug 15, 2011 1:28 am 
Offline

Joined: Sun Aug 14, 2011 9:41 pm
Posts: 11
I don't have access to a pc with a floppy drive, so the only disk images I have acces to are the ones posted at http://launch.groups.yahoo.com/group/MP ... ndLibrary/

Unfortunately, most of these files are not read by the HXC software. I did get Greytsounds_808Alt.img to convert to an HFE, but it is double the size I would expect it to be, and the MPC60 doesn't recognize it.


Top
 Profile  
 
PostPosted: Mon Aug 15, 2011 8:49 am 
Offline
Site Admin

Joined: Fri Oct 20, 2006 12:12 am
Posts: 4530
Location: Paris
jchiet wrote:
I don't have access to a pc with a floppy drive, so the only disk images I have acces to are the ones posted at http://launch.groups.yahoo.com/group/MP ... ndLibrary/

Unfortunately, most of these files are not read by the HXC software. I did get Greytsounds_808Alt.img to convert to an HFE, but it is double the size I would expect it to be, and the MPC60 doesn't recognize it.


Can you send me one of these images please ?

Own react the floppy access LED of the floppy emulator when the MPC try to read the disk ?


Top
 Profile  
 
PostPosted: Mon Aug 15, 2011 10:32 am 
Offline

Joined: Sun Aug 14, 2011 9:41 pm
Posts: 11
You can D/L the one image file I was able to open with the HXC software at http://www.mediafire.com/?0m2cw8456ij9hyi

The floppy access light seemed to behave properly when accessing the SD card.

Thank you!


Top
 Profile  
 
PostPosted: Mon Aug 15, 2011 11:30 am 
Offline
Site Admin

Joined: Fri Oct 20, 2006 12:12 am
Posts: 4530
Location: Paris
jchiet wrote:
You can D/L the one image file I was able to open with the HXC software at http://www.mediafire.com/?0m2cw8456ij9hyi

The floppy access light seemed to behave properly when accessing the SD card.

Thank you!


Ok this seems to be a classical 80*9*2*512 disk.
I have just send to your email a file to test.


Top
 Profile  
 
PostPosted: Mon Aug 15, 2011 5:25 pm 
Offline

Joined: Sun Aug 14, 2011 9:41 pm
Posts: 11
I thought for sure this was going to do it, as I was able to browse the disk and select the files for loading. However, Attempt to load files are greeted with the error message: "This disk is either not formatted or is bad. Either format it or use a different disk." Attempts to format are greeting with the previous error: "This disk is unusable since a defect was found in the area reserved for the file directory. Please insert another disk and try again. [Error code: ff04]).


Top
 Profile  
 
PostPosted: Wed Aug 17, 2011 9:16 am 
Offline

Joined: Sun Aug 14, 2011 9:41 pm
Posts: 11
Success! I put a tiny album up at http://goo.gl/mX3Sj and (if you're ok with this Jeff) a link to the .hfe file at http://goo.gl/LZWRo. The config is the standard shugart emulator, and I have jumpers set for a single drive with a twisted ribbon cable. I will upload a video to YouTube as soon as I can get some samples into the machine. Thank you!


Top
 Profile  
 
PostPosted: Wed Aug 17, 2011 10:14 pm 
Offline
Site Admin

Joined: Fri Oct 20, 2006 12:12 am
Posts: 4530
Location: Paris
jchiet wrote:
Success! I put a tiny album up at http://goo.gl/mX3Sj and (if you're ok with this Jeff) a link to the .hfe file at http://goo.gl/LZWRo. The config is the standard shugart emulator, and I have jumpers set for a single drive with a twisted ribbon cable. I will upload a video to YouTube as soon as I can get some samples into the machine. Thank you!


Some additionals notes :

The MPC60MKII use a 80*2*10*512 in MFM format.

--------------------------------------------------------------------------------------------
To create an empty floppy :

>"Load Raw image"

Track Type : IBM MFM
Two sides Floppy
Auto GAP3
Number of Track : 80
Sector ID start : 1
Sector size: 512
Sector per track 10
RPM : 300
Bitrate 250000
Format value : 246
Interleave: 1 (another value may increase the speed : to be tested)
Skew: 0 (another value may increase the speed : to be tested)

After push "Create Empty Floppy"

If not already done :
> Menu Settings > SDCard HxC Floppy Emulator Settings > HFE file interface mode : Uncheck auto and select Generic Shugart > OK

Finally : Export ;)

On the MPC you must initalize the file system with the format command.

That's all. ;)

(You can also use the HxC Dump tool to generate images from your floppy disk)


Top
 Profile  
 
PostPosted: Sat Aug 27, 2011 9:05 pm 
Offline

Joined: Tue Jan 11, 2011 5:08 pm
Posts: 15
Hi,

I have a fresh HXC floppy emulator working in my MPC 60 (with metal case, OS version 3.11). First I tried a standard IBM formatted 720K DD disk image. Now I tried it with the specs Jeff provided (10 Sectors/track, instead 9). I formatted the image with the MPC 60 and now I can use the full 793K as written in the MPC 60 manual.

There is just a small problem. Nearly every time I try to access the disk, the MPC says that there is no disk in the drive. I have to umount/mount the disk image and then the disk is recognized. This happens directly after booting and after a successful disk access.

Do you have the same problem jchiet? I use the same jumper settings.


Top
 Profile  
 
PostPosted: Sat Aug 27, 2011 9:07 pm 
Offline

Joined: Tue Jan 11, 2011 5:08 pm
Posts: 15
Oh I forgot. The floppy access LED is constantly on when switching on the MPC. When unmounting/mounting the floppy Image the LED goes off.


Top
 Profile  
 
PostPosted: Sun Aug 28, 2011 4:34 am 
Offline

Joined: Sun Aug 14, 2011 9:41 pm
Posts: 11
Hi Jandoe,

I think I noticed the floppy light being continuously on before I filed down and reversed the floppy drive ribbon cable. Did you remove the little nub on the ribbon plug that forces it to install in one particular direction? I have no issues with the drive staying mounted currently.

Hope that helps.


Top
 Profile  
 
PostPosted: Sun Aug 28, 2011 10:08 am 
Offline
Site Admin

Joined: Fri Oct 20, 2006 12:12 am
Posts: 4530
Location: Paris
jandoe wrote:
Hi,

I have a fresh HXC floppy emulator working in my MPC 60 (with metal case, OS version 3.11). First I tried a standard IBM formatted 720K DD disk image. Now I tried it with the specs Jeff provided (10 Sectors/track, instead 9). I formatted the image with the MPC 60 and now I can use the full 793K as written in the MPC 60 manual.

There is just a small problem. Nearly every time I try to access the disk, the MPC says that there is no disk in the drive. I have to umount/mount the disk image and then the disk is recognized. This happens directly after booting and after a successful disk access.

Do you have the same problem jchiet? I use the same jumper settings.


Don't forget to force the shugart mode.

If already done try another floppy cable.


Top
 Profile  
 
PostPosted: Tue Jun 03, 2014 10:49 pm 
Offline

Joined: Tue Jul 24, 2012 10:55 am
Posts: 7
Hi guys,

I put the HXC in my SP1200 last year and it works great, ive recently put an HXC in my MPC60II too....

I downloaded the empty formatted MPC60 disk images that 12bitski uploaded (thanks man) and have successfully saved samples from the MPC to to the SD card and reloaded them again after a reboot, so that's great...... SD is working well

But the other thing I really want to be able to do is to convert some original MPC60 disk images into .hfe format files and load them onto the SD card for the MPC to read

The MPC60 images I want can be found here: http://www.mpc-forums.com/viewtopic.php?f=4&t=163167 (the first post)

I used the "Load Raw Image" option in HXCFloppyEmulator
Then using Jeff's suggested settings he posted a few posts above:

Track Type : IBM MFM
Two sides Floppy
Auto GAP3
Number of Track : 80
Sector ID start : 1
Sector size: 512
Sector per track 10
RPM : 300
Bitrate 250000
Format value : 246
Interleave: 1 (another value may increase the speed : to be tested)
Skew: 0 (another value may increase the speed : to be tested)

Then I click "Load Raw File"
I navigate to the MPC60 disk image on my hard disk and the software loads it OK.

Then I click Export and move the converted file (with the new .hfe extension) to the SD card and into the MPC.

But when I load the file from SD card in the MPC60II I get an error, it shows me the correct name of the file in the MPC, but when I try to load it I get an error message on the MPC:

"attention! this file was created by a unit with a later system software version You must upgrade the system in this unit before reading this file"

I have the latest software, version 3.10E... so I know its not that, so im sure the HXCFloppyEmulator software is not quite importing/converting the disk images correctly... it seems tantalisingly close, but no cigar yet..... yet

So, Jeff / 12bitski or anyone else please could you help out with this it would be really cool to have all the factory disks on an SD card.

Cheers


Top
 Profile  
 
PostPosted: Tue Jun 03, 2014 11:10 pm 
Offline
Site Admin

Joined: Fri Oct 20, 2006 12:12 am
Posts: 4530
Location: Paris
CrateDigger wrote:
Hi guys,

I put the HXC in my SP1200 last year and it works great, ive recently put an HXC in my MPC60II too....

I downloaded the empty formatted MPC60 disk images that 12bitski uploaded (thanks man) and have successfully saved samples from the MPC to to the SD card and reloaded them again after a reboot, so that's great...... SD is working well

But the other thing I really want to be able to do is to convert some original MPC60 disk images into .hfe format files and load them onto the SD card for the MPC to read

The MPC60 images I want can be found here: http://www.mpc-forums.com/viewtopic.php?f=4&t=163167 (the first post)

...
...



Stop. Have a look to my comments in this same thread (jeff_hxc2001) : The guy failed to make propers MPC60II images. an MPC60II image is 800KB, not 720KB...
These images are bad.

Quote:
I just tried a few of the images out by putting them onto a real disk and the majority I tried worked (Dance&Vox wouldn't work) but I noticed some of the longer samples had distortion in them. I have a usb floppy drive so onniflop won't work for me. I use a program called Floppy Image. I'm not sure if the image itself is the issue or if something went wrong when transferring the image to the disk.

I probably should have tested each image individually before posting them up. Sorry about that.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 16 posts ]  Go to page 1, 2  Next

All times are UTC + 2 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group