Akai S2000

HxC Floppy Emulator Akai Keyboards/Samplers support
Post Reply
msoutheron
Posts: 3
Joined: Wed May 13, 2015 5:06 am
Location: Sydney

Akai S2000

Post by msoutheron » Wed May 13, 2015 5:13 am

I'm trying to get the HxC emulator working on an Akai S2000.
I purchased the HxC a few years back and never got around to using it.
The s2000 boots from a floppy and I've copied the system disc onto the sd card with the HxC software but the s2000 just says insert system disc?

Jeff
Site Admin
Posts: 5581
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Akai S2000

Post by Jeff » Fri May 15, 2015 5:35 pm

msoutheron wrote:I'm trying to get the HxC emulator working on an Akai S2000.
I purchased the HxC a few years back and never got around to using it.
The s2000 boots from a floppy and I've copied the system disc onto the sd card with the HxC software but the s2000 just says insert system disc?
I think that the "S950 resistor mod " is needed here too. (1Kohms resistor to add at the R12 place on the emulator).

Have you the OS disk Image ?

msoutheron
Posts: 3
Joined: Wed May 13, 2015 5:06 am
Location: Sydney

Re: Akai S2000

Post by msoutheron » Sat May 16, 2015 7:56 am

yes I installed the os onto the sd card.
should I send it too you?

pascalc
Posts: 10
Joined: Wed Jan 27, 2016 10:47 pm

Re: Akai S2000

Post by pascalc » Fri Jan 29, 2016 10:10 am

Hi,

I recently bought a USB HxC Floppy emulator rev D. I would like to connect my Akai S2000 to it and read in this topic that I need to solder a 1kOhm resistance at R12 on the circuit board.

I have looked at the circuit board and to my understanding there is already some sort of resistance (or other component) at the R12 location. Do I have to remove this component in order to add the 1kOhm resistance or has these instructions changed?

Thanks
/Pascal

Jeff
Site Admin
Posts: 5581
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Akai S2000

Post by Jeff » Sun Jan 31, 2016 2:23 pm

You may try to connect it without the resistor.

pascalc
Posts: 10
Joined: Wed Jan 27, 2016 10:47 pm

Re: Akai S2000

Post by pascalc » Tue Feb 02, 2016 6:25 pm

Hi,

I tried to use the USB Floppy Emulator with the AKAI S2000 today with the following settings:

80 tracks
10 sectors/track
sector id start: 1
interleave: 1
sector size: 1024
number of sides: 2

Next I load this image http://wiw.org/~meta/download.php?file=2 as a raw file onto the emulator.

Then I start my AKAI S2000 and it says "Insert S2000 system disk" forever.

The two middle leds on the emulator shine with a steady light after some initial blinking when I turn on the sampler. The power lead is green and the last one is mostly orange but sometimes blinks.

Is there anything obvious that I am missing?

Thanks
/Pascal

Jeff
Site Admin
Posts: 5581
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Akai S2000

Post by Jeff » Tue Feb 09, 2016 9:21 am

What say the usb status window ?

pascalc
Posts: 10
Joined: Wed Jan 27, 2016 10:47 pm

Re: Akai S2000

Post by pascalc » Wed Apr 13, 2016 9:08 pm

Hi,

My apologies for the late response.

I'm not entirely sure where to find the usb status window but if it what I think it is (Open the USB HxC Floppy Emulator settings and status window) then it says "USB HxC Floppy Emulator ready!"

It also seems to transmit data because in the USB statistics and settings pane I can see the following values:

Max settle time: 24 ms
Min settle time: 12 ms
Data throughput: ~129kB/sec
Data sent: keeps increasing but is after three attempts of sending the os disc it is above 50MB
Packet sent: 39p/s

I have also tried to "invert" the cable i.e. turning the plug upside down and then run the same procedure as above but got the same result.

Thanks
/Pascal

Jeff
Site Admin
Posts: 5581
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Akai S2000

Post by Jeff » Thu Apr 14, 2016 8:05 am

All seems fine.
Try to load some S950 images from this archive :

http://hxc2001.com/download/floppy_driv ... Images.zip

pascalc
Posts: 10
Joined: Wed Jan 27, 2016 10:47 pm

Re: Akai S2000

Post by pascalc » Sat Apr 16, 2016 4:44 pm

Hi!

Thanks for the advice. I have tried to load a quite some of those Akai S950 images.

I'm sure if I load the images correctly. This is what I do:

* Press the "Load" button
* Select one of the HFE image files from the S950 zip
* Close the file selector dialog

Is this how to properly load these files?

Anyway, when I follow the above procedure I get no reaction what so ever from the S2000.

I discovered that it seems as if the floppy emulator has properly detected its mode. In the mode pane of the settings and status window the auto checkbox is selected and the drop down value is "AKAI S950 HD". This is probably the value it should have I guess.

I also found that there is the possibility to view the log. I selected error, info and debug and attached the log file. Not sure if there is anything valuable there...

BR
/Pascal

Log for DSKA0021:

INFO 0 : Checking C:\ctrlr\floppyImages\AkaiS950\DSKA0021.HFE
DEBUG : KryoFluxStream_libIsValidDiskFile
DEBUG : libIsValidDiskFile n0 return -2
DEBUG : DMS_libIsValidDiskFile
DEBUG : DMS_libIsValidDiskFile : non DMS file !
DEBUG : libIsValidDiskFile n1 return -2
DEBUG : ADZ_libIsValidDiskFile
DEBUG : ADZ_libIsValidDiskFile : non ADZ file !
DEBUG : libIsValidDiskFile n2 return -2
DEBUG : EXTADF_libIsValidDiskFile
DEBUG : EXTADF_libIsValidDiskFile : non Extended ADF file !
DEBUG : libIsValidDiskFile n3 return -2
DEBUG : OLDEXTADF_libIsValidDiskFile
DEBUG : OLDEXTADF_libIsValidDiskFile : non Old Extended ADF file !
DEBUG : libIsValidDiskFile n4 return -2
DEBUG : FDI_libIsValidDiskFile
DEBUG : FDI_libIsValidDiskFile : non FDI file !
DEBUG : libIsValidDiskFile n5 return -2
DEBUG : ADF_libIsValidDiskFile
DEBUG : ADF_libIsValidDiskFile : non ADF file !
DEBUG : libIsValidDiskFile n6 return -2
DEBUG : ACORNADF_libIsValidDiskFile
DEBUG : ACORNADF_libIsValidDiskFile : non Acorn ADF file !
DEBUG : libIsValidDiskFile n7 return -2
DEBUG : CPCDSK_libIsValidDiskFile
DEBUG : CPCDSK_libIsValidDiskFile : non CPC Dsk file !
DEBUG : libIsValidDiskFile n8 return -2
DEBUG : DIM_libIsValidDiskFile
DEBUG : DIM_libIsValidDiskFile : non DIM file !
DEBUG : libIsValidDiskFile n9 return -2
DEBUG : STX_libIsValidDiskFile
DEBUG : STX_libIsValidDiskFile : non STX file !
DEBUG : libIsValidDiskFile n10 return -2
DEBUG : STT_libIsValidDiskFile
DEBUG : STT_libIsValidDiskFile : non STT file !
DEBUG : libIsValidDiskFile n11 return -2
DEBUG : CopyQm_libIsValidDiskFile
DEBUG : CopyQm_libIsValidDiskFile : bad header tag !
DEBUG : libIsValidDiskFile n12 return -2
DEBUG : TeleDisk_libIsValidDiskFile
DEBUG : TeleDisk_libIsValidDiskFile : bad header tag !
DEBUG : libIsValidDiskFile n13 return -2
DEBUG : MSA_libIsValidDiskFile
DEBUG : MSA_libIsValidDiskFile : non MSA file !
DEBUG : libIsValidDiskFile n14 return -2
DEBUG : STW_libIsValidDiskFile
DEBUG : STW_libIsValidDiskFile : non STW file !
DEBUG : libIsValidDiskFile n15 return -2
DEBUG : IMZ_libIsValidDiskFile
DEBUG : IMZ_libIsValidDiskFile : non IMZ file !
DEBUG : libIsValidDiskFile n16 return -2
DEBUG : MFM_libIsValidDiskFile
DEBUG : MFM_libIsValidDiskFile : non MFM file !
DEBUG : libIsValidDiskFile n17 return -2
DEBUG : OricDSK_libIsValidDiskFile
DEBUG : OricDSK_libIsValidDiskFile : non OricDSK file !
DEBUG : libIsValidDiskFile n18 return -2
DEBUG : ST_libIsValidDiskFile
DEBUG : ST_libIsValidDiskFile : non ST file !
DEBUG : libIsValidDiskFile n19 return -2
DEBUG : W30_libIsValidDiskFile
DEBUG : W30_libIsValidDiskFile : non W30/S50/S330/S550 file !
DEBUG : libIsValidDiskFile n20 return -2
DEBUG : IPF_libIsValidDiskFile
DEBUG : IPF_libIsValidDiskFile : non IPF file !
DEBUG : libIsValidDiskFile n21 return -2
DEBUG : TI99V9T9_libIsValidDiskFile
DEBUG : TI99V9T9_libIsValidDiskFile : non TI99 V9T9 file!
DEBUG : libIsValidDiskFile n22 return -2
DEBUG : AMIGADOSFSDK_libIsValidDiskFile C:\ctrlr\floppyImages\AkaiS950\DSKA0021.HFE
DEBUG : AMIGADOSFSDK_libIsValidDiskFile : non AMIGADOSFSDK file ! (it's not a directory)
DEBUG : libIsValidDiskFile n23 return -2
DEBUG : Prophet_libIsValidDiskFile
DEBUG : Prophet_libIsValidDiskFile : non Prophet file !
DEBUG : libIsValidDiskFile n24 return -2
DEBUG : IMG_libIsValidDiskFile
DEBUG : IMG_libIsValidDiskFile : non IMG file !
DEBUG : libIsValidDiskFile n25 return -2
DEBUG : FLPPCM_libIsValidDiskFile
DEBUG : FLPPCM_libIsValidDiskFile : non FLP file !
DEBUG : libIsValidDiskFile n26 return -2
DEBUG : MSX_libIsValidDiskFile
DEBUG : MSX_libIsValidDiskFile : non MSX IMG file !
DEBUG : libIsValidDiskFile n27 return -2
DEBUG : FAT12FLOPPY_libIsValidDiskFile
DEBUG : FAT12FLOPPY_libIsValidDiskFile : non FAT12FLOPPY file !
DEBUG : libIsValidDiskFile n28 return -2
DEBUG : HFE_libIsValidDiskFile
DEBUG : HFE_libIsValidDiskFile : HFE file !
INFO 0 : File loader found : HXC_HFE (SD Card HxCFE HFE file Loader)
INFO 0 : Loading C:\ctrlr\floppyImages\AkaiS950\DSKA0021.HFE
DEBUG : HFE_libIsValidDiskFile
DEBUG : HFE_libIsValidDiskFile : HFE file !
INFO 0 : file loader found!
DEBUG : HFE_libLoad_DiskFile C:\ctrlr\floppyImages\AkaiS950\DSKA0021.HFE
DEBUG : HFE File : 80 track, 2 side, 500000 bit/s, -1 sectors, interface mode Unknow!, track encoding:ISOIBM_MFM_ENCODING
DEBUG : HFE File : reading track 0, track size:50176 - file offset:00000400
DEBUG : HFE File : reading track 1, track size:50176 - file offset:0000C800
[...]
DEBUG : HFE File : reading track 79, track size:50176 - file offset:003C8000
INFO 0 : USB HxCFloppyEmulator :Convert track data...
DEBUG : USB Track 0 Size: 50572 bytes
DEBUG : USB Track 1 Size: 50572 bytes
[...]
DEBUG : USB Track 79 Size: 50572 bytes
INFO 0 : Starting emulation...

Jeff
Site Admin
Posts: 5581
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Akai S2000

Post by Jeff » Tue Apr 19, 2016 8:36 am

Ok. Can you try to connect the floppy ribbon to the other way ?

pascalc
Posts: 10
Joined: Wed Jan 27, 2016 10:47 pm

Re: Akai S2000

Post by pascalc » Wed Apr 20, 2016 8:51 pm

Hi,

Thanks for the advice but unfortunately that did not help.

* I have tried to use the emulator with the floppy cable connected in both ways.
* I have also tried with a twisted floppy cable (the original is not twisted) in both ways
* I have gone through all the S950 images
* I have also tried my S2000 raw image

If I have the cable connected in one way all four LEDs are illuminated at all time (as soon as I load an image) and the other way the leftmost and the two rightmost are illuminated while the second from the left blinks.

Are you sure that the S950 images should work with the S2000? I opened the log window and discovered that it says "DEBUG : USB Track XX Size: 50572 bytes" for the S950 images while it says "DEBUG : USB Track XX Size: 44454 bytes" using my Akai S2000 image.

I really appreciate your help as it would be so cool to get this thing working!

Thanks
/Pascal

pascalc
Posts: 10
Joined: Wed Jan 27, 2016 10:47 pm

Re: Akai S2000

Post by pascalc » Wed May 11, 2016 8:55 pm

Hi again,

I have been testing some more but still no luck.

I'm starting to think that I might be doing things completely wrong. I have tried to load the S950 disks you provided a link to.

Are these OS disks? My Akai S2000 is only saying "Insert S2000 system disk". Perhaps I'm trying to load non OS disks?

Is there any way for me to debug the communication between the S2000 and the USB HxC emulator?

Thanks,
/Pascal

pascalc
Posts: 10
Joined: Wed Jan 27, 2016 10:47 pm

Re: Akai S2000

Post by pascalc » Thu Jun 02, 2016 10:57 pm

Hi,

I finally managed to get it to work!

By selecting "Akai S3000 3"5 HD Floppy" as disk layout in the "Load raw image" window I could then load first the OS disk and then sample floppies onto the S2000.

BR
/Pascal

BHOBuds_dot_com
Posts: 4
Joined: Sun Feb 12, 2017 7:37 am

Re: Akai S2000

Post by BHOBuds_dot_com » Sun Feb 12, 2017 7:44 am

I am posting in this thread because it is the main google result and helped me get Gotek HxC fully working on my akai s2000.
To help anyone (and probably myself later on) I uploaded some useful disk images.

The first link is to two HFE disk images. DSKA0000 is the AKAI S2000 2.00 OS Boot Floppy with the S2KDIE sample, the same disk posted above by pascalc http://wiw.org/~meta/download.php?file=2 ) DSKA0001 is a blank disk formatted by S2000 and is ready to save anything onto.

The second link is a bunch of prenamed S2000 blank disks. It contains DSKA0002 thru DSKA0099.

Two disk images (OS 2.00 and one blank floppy) https://mega.nz/#!J9hUhbCb!3_g5XLyxSCpA ... emwbxwDaZg
98 blank disks for S2000/S3000 https://mega.nz/#!s8YCSaCZ!FPCy1GzOq2EB ... w4aLx3tGRE

Format a flash drive as FAT32, dump the contents of the first link to your drive, and it will start up into the latest OS 2.00
Hope this helps.

Post Reply