HP 54624A Oscilloscope & TEAC FD-05HF - Failed Startup

Post Reply
HxC-Harry
Posts: 6
Joined: Sun Jul 21, 2019 9:10 am

HP 54624A Oscilloscope & TEAC FD-05HF - Failed Startup

Post by HxC-Harry » Sun Jul 21, 2019 9:55 am

I cannot get a 26pinZIF SLIM to work in an HP 54624A, but it is listed as working in the HP 54642D which is a very similar unit. I have used these emulators in other equipment with no problems - my HP16500C logic analyzer works just fine. So very frustrated that I cannot get it to work with the scope.

Setup: HxC SLIM with ID0A ON and all others off. I think this is the standard setting for 26pinZIF versions. No other switches should be used.
Image File: Using 1.44 DOS images from the Slim_SDHXCFE_DOSHD download package
HxC Setings: I have tried lots of combinations of HFE file Interfacemode / SD HxC Floppy Emulator Interface setting. All combinations of IBM modes and generic Shugart modes, always get the same error

The scope always give the same error at startup "Failed Startup Initialization". Putting back the original FDD works fine with a 1.44 DOS formatted disk.

I don't quite know how the HFE file Interfacemode - SD HxC setting and the actual image file interact. If I am getting a failed to initialise error, which settings are more likely to be the cause?

I have looked at TEAC FD-05HF docs but this did not seem to help to work out the interface IBM/Shugart?? The HP scope docs don't help here either...

I hope somebody may have some working files from the HP54xxx scope family that could help.

Thanks for any help!

Jeff
Site Admin
Posts: 6697
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: HP 54624A Oscilloscope & TEAC FD-05HF - Failed Startup

Post by Jeff » Sun Jul 21, 2019 10:02 am

You may need to populate the missing pull up resistors on the slim pcb. add 1K ohms resistors on R4,R8 and R9 (0805 smd resistors).
IBM PC HD should be the right interface mode with ID0-A set to ON.

HxC-Harry
Posts: 6
Joined: Sun Jul 21, 2019 9:10 am

Re: HP 54624A Oscilloscope & TEAC FD-05HF - Failed Startup

Post by HxC-Harry » Mon Jul 22, 2019 12:37 pm

Jeff, thanks for the fast reply!

I have installed 3 pullups, but same problem. "Failed Startup Initialization" :(

Before I start probing on pins with the logic analyzer, do you have any other ideas, or does anyone else have a working setup I can copy.

My setup is attached, it would help if you can verify that this setup looks OK.

The HFE is from the DOS144 downloadable images.

Thanks again for any more suggestions.
Attachments
HP54624A.jpg
HP54624A.jpg (89.52 KiB) Viewed 436 times

Jeff
Site Admin
Posts: 6697
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: HP 54624A Oscilloscope & TEAC FD-05HF - Failed Startup

Post by Jeff » Mon Jul 22, 2019 1:57 pm

HxC-Harry wrote:
Mon Jul 22, 2019 12:37 pm
Jeff, thanks for the fast reply!

I have installed 3 pullups, but same problem. "Failed Startup Initialization" :(

Before I start probing on pins with the logic analyzer, do you have any other ideas, or does anyone else have a working setup I can copy.

My setup is attached, it would help if you can verify that this setup looks OK.

The HFE is from the DOS144 downloadable images.

Thanks again for any more suggestions.
Please instead use the indexed system : name the file DSKA0000.HFE and disable the startupa.hfe feature.

HxC-Harry
Posts: 6
Joined: Sun Jul 21, 2019 9:10 am

Re: HP 54624A Oscilloscope & TEAC FD-05HF - Failed Startup

Post by HxC-Harry » Tue Jul 23, 2019 2:06 pm

Thanks again Jeff, you are so helpful!

Sad to say, still not working. I tried to reflash the firmware - 2.1.2.40 and 2.1.6.14a - both same error.
Using 2.1.2.40 and the HFE images from Slim_SDHXCFE_DOSHD.zip, copied as DSKA0000.HFE and DSKB0000.HFE.
CFG as shown below
-> "Failed Startup Initialization"

I'm starting to think maybe hardware fault? Any other suggestions?? Do you think it it would be useful to put the logic analyzer on the ZIF bus and watch the startup process?? (Or maybe just order another board, if it looks most likely to be hardware)

Very grateful for your thoughts
Attachments
HP54624A-2.jpg
HP54624A-2.jpg (64.73 KiB) Viewed 421 times

Jeff
Site Admin
Posts: 6697
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: HP 54624A Oscilloscope & TEAC FD-05HF - Failed Startup

Post by Jeff » Tue Jul 23, 2019 7:34 pm

Did you hear something from the emulator when you insert the sdcard ?

HxC-Harry
Posts: 6
Joined: Sun Jul 21, 2019 9:10 am

Re: HP 54624A Oscilloscope & TEAC FD-05HF - Failed Startup

Post by HxC-Harry » Wed Jul 24, 2019 12:48 pm

Single beep on power-up,
No sound on remove SD, single beep after insert,
Single beep when pressing button, repeats every one second if button held down.

Just to check, I have flashed with HXCFESlim_V2_1_2_40.upd (58880 bytes) and with HXCFESlim_V2_1_6_14a.upd (61440 bytes).
These Slim versions are OK for the ZIF socket version?

I do not have another ZIF26 host so I cannot test directly. Can I solder a 34pin header to the ZIF board and test with 34pin cable??

Thank you again!

Jeff
Site Admin
Posts: 6697
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: HP 54624A Oscilloscope & TEAC FD-05HF - Failed Startup

Post by Jeff » Wed Jul 24, 2019 4:07 pm

I found something in my archive regarding an oscilloscope in this familly : The density signal is inverted !
Try the attached files, this should work fine with your oscilloscope.
HP546XX.zip
(82.4 KiB) Downloaded 25 times

HxC-Harry
Posts: 6
Joined: Sun Jul 21, 2019 9:10 am

Re: HP 54624A Oscilloscope & TEAC FD-05HF - Failed Startup

Post by HxC-Harry » Thu Jul 25, 2019 8:55 am

Jeff - success :) and failure :(

You have succeeded - the files you sent work!

I cannot finish the job because the ribbon cable to the FDD is too short for the emulator, so I have to find another. When it is put together and working I will send you a picture for the database.

Thank you for all of your generous help. If you come to Australia one day I will buy you some beers!!

gkmaia
Posts: 4
Joined: Mon Sep 09, 2019 10:03 pm

Re: HP 54624A Oscilloscope & TEAC FD-05HF - Failed Startup

Post by gkmaia » Mon Sep 09, 2019 11:54 pm

Hi guys. My first post here.

I am struggling a bit to get my SFRM72-DU26 to work with my Agilent 54622D.

The files I saved on my Mac I can manage to see on the 54622.

https://www.youtube.com/watch?v=j70T90oJTMU

Bit the files I saved with the 54622 I can see them stored on my 54622, but cannot see them on my Mac.

https://www.youtube.com/watch?v=l0uK3eQn0ME

I am a bit confused about the role of those buttons. Manual says that one of the buttons intends to move files from USB Flash to Gotek memory. And the other is to move files from Gotek's memory into the USB Flash.

But in between there is a stage where you get the Gotek ready to capture files saved by the 54622.

Not sure how to get it done.

Jeff
Site Admin
Posts: 6697
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: HP 54624A Oscilloscope & TEAC FD-05HF - Failed Startup

Post by Jeff » Tue Sep 10, 2019 7:35 am

Have you installed the HxC Firmware on this ?

:arrow: https://hxc2001.com/store/ :?:

gkmaia
Posts: 4
Joined: Mon Sep 09, 2019 10:03 pm

Re: HP 54624A Oscilloscope & TEAC FD-05HF - Failed Startup

Post by gkmaia » Wed Sep 11, 2019 5:18 am

No, did not. It is working now. I had to dig some manuals and come up with the following. Was confused how the "emulation" type of thing worked.

Left button - transfer data from built-in memory into USB flash drive
Right button - transfer data from USB flash drive into built-in memory

Read sequence

Insert the USB flash
Red LED comes on
Red LED goes off after 1-20 sec
54622 read file

Write sequence

Insert the USB flash
Red LED comes on
Red LED goes off after 1-20 sec
Press OUT
Red LED stays on
54622 write file
Wait Green LED to go off
Press OUT
Red LED goes off
Remove the USB flash

Post Reply