MSX1 and HxC

HxC Floppy Emulator on MSX and compatible support
Post Reply
Turrican
Posts: 6
Joined: Mon Jan 23, 2012 11:21 am

MSX1 and HxC

Post by Turrican » Mon Jan 23, 2012 6:17 pm

Hello all!
I have a MSX 1 and an IDE interface for it.
I bought the HxC2001 and I´m trying to make it work with no success...
I have the 5 1/4" disk drive and it works with my IDE interface. So, how can I make HxC to work with my MSX?

MSX has a standard IDE interface (34 pins) and uses DSK images.
The File Converter has the MSX2 option to convert DSK images.
Can I use this option (MSX2) to export my images?

I used it but the MSX didin´t reconize the images (or the disk).

I think the MSX 1 uses the standard Shugart/IBM-PC disk drives.
With the 5 1/4" disk drive I use a non-cross flat-cable.
Thanks!!!

mau_rizio
Posts: 69
Joined: Tue May 05, 2009 5:08 pm

Re: MSX1 and HxC

Post by mau_rizio » Mon Jan 23, 2012 7:01 pm

Hi Turrican,
what msx model and what ide? You say 5 1/4" disk so you have a spectravideo?
I've tested the hxc on a vg8020 with vy-010 disk interface without any problem.
An yes, for exporting you have to use MSX2 option.

bye
mau

Turrican
Posts: 6
Joined: Mon Jan 23, 2012 11:21 am

Re: MSX1 and HxC

Post by Turrican » Mon Jan 23, 2012 7:15 pm

Hi mau_rizio.
I have a Brazilian MSX (the Expert 1.0).
I´m from Brazil. :)

My IDE interface is a DDX (made in Brazil). A cartridge interface.
It works on both 5 1/4 and 3 1/2 disk drives and I have an external 5 1/4 disk drive.

I´ll test with different jumper settings.

Thanks!

Turrican
Posts: 6
Joined: Mon Jan 23, 2012 11:21 am

Re: MSX1 and HxC

Post by Turrican » Mon Jan 23, 2012 10:15 pm

Didn't work! :(

Normal cable, twisted-cable, changing the jumper setting, using Amiga, IBM-PC 720K, MSX2 settings. :(

And with the 5 1/4"disk drive, it works. :(

Jeff
Site Admin
Posts: 5626
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: MSX1 and HxC

Post by Jeff » Mon Jan 23, 2012 10:25 pm

Turrican wrote:Didn't work! :(

Normal cable, twisted-cable, changing the jumper setting, using Amiga, IBM-PC 720K, MSX2 settings. :(

And with the 5 1/4"disk drive, it works. :(
Ok but what about the disk image you are using ? can you send me it ?

Turrican
Posts: 6
Joined: Mon Jan 23, 2012 11:21 am

Re: MSX1 and HxC

Post by Turrican » Tue Jan 24, 2012 12:00 am

Hi Jeff!
An email was sent with 2 disk images.
Thanks!

Turrican
Posts: 6
Joined: Mon Jan 23, 2012 11:21 am

Re: MSX1 and HxC

Post by Turrican » Tue Jan 24, 2012 1:32 am

SOLVED!!!!!!!!!!!
8)

Brazilian MSX 1 works great with HxC!
Thanks to Jeff!!!

Jeff
Site Admin
Posts: 5626
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: MSX1 and HxC

Post by Jeff » Tue Jan 24, 2012 1:39 am

The "solution" :
The Floppy access led should be on only when the MSX try to read it...

Reverse the floppy cable and tell me how react the leds !!

----- Original Message -----
From: al_colella
To: hxc2001
Sent: Monday, January 23, 2012 11:33 PM
Subject: RE: MSX 1 disk image


Yes, all the leds are always on.
How the leds should stay? :)


--------------------------------------------------------------------------------
From: hxc2001
To: al_colella
Subject: Re: MSX 1 disk image
Date: Mon, 23 Jan 2012 23:28:48 +0100


>Well, when I load the file in HxC, the 3 lights stay on (red, yellow and green).
So all led is always on ?
In this case try to reverse the floppy cable on the HxC side OR on the MSX side.

----- Original Message -----
From: al_colella
To: hxc2001
Sent: Monday, January 23, 2012 11:23 PM
Subject: RE: MSX 1 disk image

Well, when I load the file in HxC, the 3 lights stay on (red, yellow and green).
When the MSX try to access the emulator, nothing happens...



--------------------------------------------------------------------------------
From: hxc2001
To: al_colella
Subject: Re: MSX 1 disk image
Date: Mon, 23 Jan 2012 23:15:32 +0100


no particular problem with these images.
have you tried the ID0-Drive A jumper setting ?
How react the floppy emulator access LED when the msx try to access it ?

Post Reply