HxC SDCard Floppy Emulator on Philips NMS8255/50

HxC Floppy Emulator on MSX and compatible support
Post Reply
Wild Penquin
Posts: 10
Joined: Sun Sep 18, 2011 3:23 pm

HxC SDCard Floppy Emulator on Philips NMS8255/50

Post by Wild Penquin » Sun Sep 18, 2011 6:57 pm

Hi all!

I can't get the emulator to work on this computer. It already has one (had two, but I removed the other one) floppy drive. I'd like the emulator to work as drive A only (not sure I can connect two drives via one cable to the NMS825X?, but if I can, maybe later as both A+B; but for the time being I'd like to leave one real drive in place).

AFAIK the internal floppy connectors on NMS825X/80 should be standard PC type, except that you have a connector for both drives, i.e. you can't connect two drives to the same cable as on PC (at least this is the default setup); but I'm not sure. And, also disk A/B is selected by jumpers on the drives (not by twisting / choosing the connector before / after the twisted part, as on PC). You could put a PC floppy drive in, with minor modifications only (having to do with the fact that PC drives do not have any jumpers...), I think.

Has anyone set up the emulator on this computer? How did you set the Jumpers on the HxC emulator? What kind of cable did you use?

Here's what I have done / tried so far:
  • I have but the .CFG file to the SD card along with a bunch of disk images converted to .HFE. I copied the files from Linux command promt to the SD card - I have no Windows (except at the walls, hehe) here so I'm not comfortable with the manager software.
  • I tried with two different cables (the one that came with the MSX, non-twisted, and a PC type, with only one connector, and part of the cable twisted - i.e. "A-drive only" type cable).
  • I tried all even slightly sensible seeming jumper setting on the HxF I could come up with.
  • Couldn't find the NMS825X floppy connector pinouts anywhere, so can't be sure how I should set the IDx jumpers....
    *Tried without the B-drive installed. Couldn't get anything to work this way
In short, here are my results: I either get the drive to work in "tandem" with the B drive, i.e. the MSX can only try to read B-drive (when trying to read A-drive, I get "Drive not ready", when reading drive B, of coure I just get an I/O error. I could boot a MSXDOS1 image, but no other images (the MSX jsut boots to BASIC and couldn't even do a file listing). From the DOS prompt, I could list the disks contents, but if I change the disk image, I will only get "Drive not ready" errors, even if I change back to the DOS disk image I just booted from! Couldn't boot any other images.

Any tips, what to try next?

Wild Penquin
Posts: 10
Joined: Sun Sep 18, 2011 3:23 pm

Re: HxC SDCard Floppy Emulator on Philips NMS8255/50

Post by Wild Penquin » Sun Sep 18, 2011 9:49 pm

Got it working :wink:

The problem was with image files - it seems that the converter autodetects / deduces something about the format according to file ending, so part of my image files werer bad. Some of my disks are .dsk and some .img (although they are in the same format, just the ending is different).

Anyways, I got confused because of the above, and tried different jumper settings, which caused all other weird behaviour described above :twisted: Renaming all to .dsk and re-converting to .hfe seems to take care of that issue.

Then I needed to set the Jumpers according to "Atari ST / Amiga / Shugart". Using a twisted cable. Everything seems to work OK - I tried with the other internal drive as drive B, or both drives on the emulator and no internal drive at all :D

- Ville

Jeff
Site Admin
Posts: 5746
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: HxC SDCard Floppy Emulator on Philips NMS8255/50

Post by Jeff » Sun Sep 18, 2011 10:55 pm

Good to see that all works now ! :D

Turrican
Posts: 6
Joined: Mon Jan 23, 2012 11:21 am

Re: HxC SDCard Floppy Emulator on Philips NMS8255/50

Post by Turrican » Mon Jan 23, 2012 11:31 am

Hi!!
Is this Phillips a MSX model 1?
I have one and an IDE interface for MSX.
I bought the HxC and I´m trying to make it work.
I´ll try your configurations.

Thanks.

Post Reply