HxC SD Floppy Emulator hangs when powered on when connected to the H89.

General discussion forum - for all that doesn't fit in any other category.
Post Reply
norby
Posts: 10
Joined: Fri May 08, 2009 4:54 pm
Location: Seattle, WA
Contact:

HxC SD Floppy Emulator hangs when powered on when connected to the H89.

Post by norby » Wed Apr 18, 2018 7:58 am

If I power-up the H89 first and the I power-up the HxC emulator, the HxC fails to initialize. The LCD displays garbage characters.

If I power-up first the HxC and then followed by the H89, everything works fine.

It seems that there is some leakage voltage going into the HxC via the floppy cable when the H89 is power up first.
Norby

Jeff
Site Admin
Posts: 5582
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: HxC SD Floppy Emulator hangs when powered on when connected to the H89.

Post by Jeff » Wed Apr 18, 2018 8:42 am

norby wrote:
Wed Apr 18, 2018 7:58 am
If I power-up the H89 first and the I power-up the HxC emulator, the HxC fails to initialize. The LCD displays garbage characters.

If I power-up first the HxC and then followed by the H89, everything works fine.

It seems that there is some leakage voltage going into the HxC via the floppy cable when the H89 is power up first.
Yes. What you are doing is bad ;). The HxC is "powered" with the floppy bus pull-up through the ic clamping diodes and internal hxc pull-up.
In fact the HxC is initialized, but the screen isn't. Remove the SD , wait some seconds, the screen should be reinitialized automatically.

norby
Posts: 10
Joined: Fri May 08, 2009 4:54 pm
Location: Seattle, WA
Contact:

Re: HxC SD Floppy Emulator hangs when powered on when connected to the H89.

Post by norby » Wed Apr 18, 2018 10:36 pm

Thanks for the feedback. Can you run your LCD reset routine multiple times during power-on to avoid the need to remove the SD card? I will like to remove the SD card only when the HxC is powered down.
Norby

Post Reply