2.8" QD Disk Emulation

General discussion forum - for all that doesn't fit in any other category.
Post Reply
drkathode
Posts: 3
Joined: Thu Sep 19, 2019 11:52 pm

Re: 2.8" QD Disk Emulation

Post by drkathode » Fri Sep 27, 2019 6:59 pm

Jeff wrote:
Fri Sep 27, 2019 5:46 pm
drkathode wrote:
Fri Sep 27, 2019 2:01 pm
Hello everyone and thanks for this project. I am trying to get my gotek to work on my akai X7000 and it is the first time I have used gotek and hxc firmware. I have never used the original QD unit of the Akai and therefore I don't know if the hardware works.

I have already managed to install the firmware HxCFEUSB_V3_4_7_11a_QuickDisk, formatted the USB stick in FAT32 and copied the file DSKA0003_Akai_formatted.QD. As my gotek has 7 sec display and two buttons, "nor" appears on the display. When I try to load, save or verify the akai it gets frozen and I have to restart the machine.

I have created a custom QD firmware in Indexed mode but it does not work, "err" appears on the display.
Any suggestions?
Copy the indexed cfg file to the stick and change the DSKA0003_Akai_formatted.QD file name to DSKA0000_Akai_formatted.QD.
Ok thanks, now is better; "000" appears on the display but it still freezing when I try to save or load. I can hear the relay acting (maybe a relay for activating the QD motor?) but it doesn't disconnect and everything still freeze. I'm afraid the hardware is broken. :?

Jeff
Site Admin
Posts: 6736
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: 2.8" QD Disk Emulation

Post by Jeff » Fri Sep 27, 2019 7:37 pm

drkathode wrote:
Fri Sep 27, 2019 6:59 pm
Ok thanks, now is better; "000" appears on the display but it still freezing when I try to save or load. I can hear the relay acting (maybe a relay for activating the QD motor?) but it doesn't disconnect and everything still freeze. I'm afraid the hardware is broken. :?
Have you double checked your wiring ?

drkathode
Posts: 3
Joined: Thu Sep 19, 2019 11:52 pm

Re: 2.8" QD Disk Emulation

Post by drkathode » Fri Sep 27, 2019 11:26 pm

Yeah! now IT WORKS!! :D

The problem was a jumper on an incorrect place. I totally missed it. It's indicated in the wiring diagram and I confirmed by looking to a photo that you posted. I'm really happy!

Knuckx
Posts: 4
Joined: Sat Sep 21, 2019 11:04 pm

Re: 2.8" QD Disk Emulation

Post by Knuckx » Sat Sep 28, 2019 1:29 am

Jeff wrote:
Sun Sep 22, 2019 5:49 pm
Ok. The PR-100 pinout is the same as the S-10/S-220.
But i think that you have now the right pinout.
Knuckx wrote:
Sun Sep 22, 2019 5:37 pm
So quite a lot of frustration, a multimeter and a PR-100 (which is a very similar sequencer) service manual later we get this:
Image
I can confirm that this pinout is correct and working to replace a 12 pin Mitsumi QD drive in a MT-100. All working correctly with a custom firmware build set for Roland QD mode, read and write.

Jeff, would you like a QD image written with an MT-100 (it should be the same as a PR-100, disk format wise)?

Jeff
Site Admin
Posts: 6736
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: 2.8" QD Disk Emulation

Post by Jeff » Sat Sep 28, 2019 10:02 am

Knuckx wrote:
Sat Sep 28, 2019 1:29 am
I can confirm that this pinout is correct and working to replace a 12 pin Mitsumi QD drive in a MT-100. All working correctly with a custom firmware build set for Roland QD mode, read and write.

Jeff, would you like a QD image written with an MT-100 (it should be the same as a PR-100, disk format wise)?
Super, thanks for the feedback ! :D
Yes i am interested by the image, for study and add its support to the QD toolkit software. You can send me it to hxc2001 at hxc2001.com
btw is the firmware working without the "Roland" option on the MT-100 ?

Jeff
Site Admin
Posts: 6736
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: 2.8" QD Disk Emulation

Post by Jeff » Sat Sep 28, 2019 10:04 am

drkathode wrote:
Fri Sep 27, 2019 11:26 pm
Yeah! now IT WORKS!! :D

The problem was a jumper on an incorrect place. I totally missed it. It's indicated in the wiring diagram and I confirmed by looking to a photo that you posted. I'm really happy!
Then pictures, youtube video(s) , spread the word :wink:.

Knuckx
Posts: 4
Joined: Sat Sep 21, 2019 11:04 pm

Re: 2.8" QD Disk Emulation

Post by Knuckx » Sun Sep 29, 2019 3:44 am

Jeff wrote:
Sat Sep 28, 2019 10:02 am
Yes i am interested by the image, for study and add its support to the QD toolkit software. You can send me it to hxc2001 at hxc2001.com
btw is the firmware working without the "Roland" option on the MT-100 ?
Emailed you an "empty" image and a recording of a classic MIDI file.

The firmware appears to work just as well with and without the Roland option, but I have only performed a quick test with the Roland option off (load, save, verify, check). I have returned to a firmware with the Roland option on following this testing.

Post Reply