HxC Floppy Drive Emulator

HxC Floppy Drive Emulator general information and news
It is currently Thu Jun 29, 2017 3:58 am

All times are UTC + 2 hours




Post new topic Reply to topic  [ 18 posts ]  Go to page Previous  1, 2
Author Message
PostPosted: Mon Oct 29, 2012 12:06 am 
Offline
Site Admin

Joined: Fri Oct 20, 2006 12:12 am
Posts: 4558
Location: Paris
jringmrath wrote:
The floppy cable was plugged in the same as you see in the picture on the HxC (with the blue stripe on the ribbon to the left as you are looking down and towards the rear of the drive).

I tried the ID-A jumper and Shugart settings but still no response.

Ideas?


mhhh do you have tried all jumper position ? (ID0-A,ID1-A,ID2-A,ID3-A,...)
To be sure, can you reset the hxc the factory settings ? (can be done from the embedded menu).


Top
 Profile  
 
PostPosted: Mon Oct 29, 2012 9:37 pm 
Offline

Joined: Wed Sep 26, 2012 5:46 pm
Posts: 9
I have tried all of the jumper settings as well as the various configuration modes (Shugart, etc.). I did reset the configuration as well.

This instrument normally operates like so:
When you power it on, the floppy drive light comes on but the instrument won't do anything until you put in a floppy disk that has .mid files on it. It then reads the disk and lets you choose a song number and play. It will constantly read the disk while it is playing the file.

It could be an issue with the .hfe file I made from the floppy. Since I have a Mac, I used Disk Utility to make an DiskCopy image of the floppy using my external usb floppy drive. From that .img file I used the HxC beta software to read the .img file as a raw floppy image and then saved it to the SD card as a .hfe file. I can send you the .hfe file - maybe you can see if there is an issue with the file that is preventing the Hxc from reading it.

Let me know how to send you the file.


Top
 Profile  
 
PostPosted: Wed Oct 31, 2012 8:14 am 
Offline
Site Admin

Joined: Fri Oct 20, 2006 12:12 am
Posts: 4558
Location: Paris
Some exchange done by email :

jringmrath wrote:
Success!

It reads and plays all of your test files, though the MF01_E.hfe file
seems to be the best. I also set the emulator to "Shugart" mode and
tried ID-1A with the jumper - that did it.

So what do I need to do to create the correct files here on my Mac
setup?

Jonathan

BTW, thanks for all of your help!



Jeff wrote:
You can use the HxC software to create an HFE file with the midi files :

First way :
-> Create FS Floppy -> File system type (3"5 1.44MB DSHD FAT12) -> Select directory, choose a folder on your mac with some midi files -> Create Disk.

Other way :
Create a folder containing your midi files with the name mydisk.fat1440 and drag&drop it on the main window.
of course don't put more than 1.44MB of files.
(the "mydisk" can changed as you want)

Before exporting don't forget to set the interface mode to "Generic Shugart" in the SD hxc window settings.


Some Pictures of Viscount MF-01 "Song Worker" with the HxC Floppy Emulator :

Image

Image


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 18 posts ]  Go to page Previous  1, 2

All times are UTC + 2 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group