Yamaha QX3 and the Gotek USB

HxC Floppy emulator support for all others Keyboards/Samplers...
Post Reply
PaulStahl
Posts: 33
Joined: Sun Mar 03, 2019 11:16 pm

Yamaha QX3 and the Gotek USB

Post by PaulStahl » Thu Apr 11, 2019 3:52 pm

I am using a simple 3 digit HxC flashed Gotek with my QX3 and am having similar troubles as another post here except they are using the SD card emulator.. The problems are 1.) The green light is always on and if i reverse the ribbon cable the emulator does not work.. 2.) if i format the virtual disk from the QX3 i can then save and load but if i turn off the QX3 then all data is lost and i have to start over when i turn the unit on again..Here is the link to other post which has the pin out diagram.. http://www.torlus.com/floppy/forum/view ... x+3#p11761
I am using version 3_1_23_1A.UPD Thank You...

Jeff
Site Admin
Posts: 6691
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Yamaha QX3 and the Gotek USB

Post by Jeff » Thu Apr 11, 2019 8:48 pm

PaulStahl wrote:
Thu Apr 11, 2019 3:52 pm
I am using a simple 3 digit HxC flashed Gotek with my QX3 and am having similar troubles as another post here except they are using the SD card emulator.. The problems are 1.) The green light is always on and if i reverse the ribbon cable the emulator does not work.. 2.) if i format the virtual disk from the QX3 i can then save and load but if i turn off the QX3 then all data is lost and i have to start over when i turn the unit on again..Here is the link to other post which has the pin out diagram.. http://www.torlus.com/floppy/forum/view ... x+3#p11761
I am using version 3_1_23_1A.UPD Thank You...
> 1.) The green light is always on
This is normal with the QX3 since the drive select is grounded in the machine.

Update with the firmware you will receive in your yahoo email box.

PaulStahl
Posts: 33
Joined: Sun Mar 03, 2019 11:16 pm

Re: Yamaha QX3 and the Gotek USB

Post by PaulStahl » Thu Apr 11, 2019 10:48 pm

Jeff wrote:
Thu Apr 11, 2019 8:48 pm
PaulStahl wrote:
Thu Apr 11, 2019 3:52 pm
I am using a simple 3 digit HxC flashed Gotek with my QX3 and am having similar troubles as another post here except they are using the SD card emulator.. The problems are 1.) The green light is always on and if i reverse the ribbon cable the emulator does not work.. 2.) if i format the virtual disk from the QX3 i can then save and load but if i turn off the QX3 then all data is lost and i have to start over when i turn the unit on again..Here is the link to other post which has the pin out diagram.. http://www.torlus.com/floppy/forum/view ... x+3#p11761
I am using version 3_1_23_1A.UPD Thank You...
> 1.) The green light is always on
This is normal with the QX3 since the drive select is grounded in the machine.

Update with the firmware you will receive in your yahoo email box.
I tried the new firmware but unfortunately the problem remains.. I must first format the .hfe file from the QX3 then i can save and load but when I turn off the machine I lose all data and must start over.. very strange to lose the songs on the usb when I power down..

Jeff
Site Admin
Posts: 6691
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Yamaha QX3 and the Gotek USB

Post by Jeff » Thu Apr 11, 2019 11:24 pm

I think that nothing was recorded for some reasons. But this can be also a FAT compatibility issue.
Can you send me the modified hfe to hxc2001 @ hxc2001.com ?

PaulStahl
Posts: 33
Joined: Sun Mar 03, 2019 11:16 pm

Re: Yamaha QX3 and the Gotek USB

Post by PaulStahl » Fri Apr 12, 2019 3:54 am

Jeff wrote:
Thu Apr 11, 2019 11:24 pm
I think that nothing was recorded for some reasons. But this can be also a FAT compatibility issue.
Can you send me the modified hfe to hxc2001 @ hxc2001.com ?
Ok thank you, i sent a file that was formatted with the QX3 and should have a short song on it but i think does not ..

Jeff
Site Admin
Posts: 6691
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Yamaha QX3 and the Gotek USB

Post by Jeff » Fri Apr 12, 2019 10:51 am

PaulStahl wrote:
Fri Apr 12, 2019 3:54 am
Jeff wrote:
Thu Apr 11, 2019 11:24 pm
I think that nothing was recorded for some reasons. But this can be also a FAT compatibility issue.
Can you send me the modified hfe to hxc2001 @ hxc2001.com ?
Ok thank you, i sent a file that was formatted with the QX3 and should have a short song on it but i think does not ..
just sent back something to test by email.

PaulStahl
Posts: 33
Joined: Sun Mar 03, 2019 11:16 pm

Re: Yamaha QX3 and the Gotek USB

Post by PaulStahl » Sat Apr 13, 2019 3:32 am

Jeff wrote:
Fri Apr 12, 2019 10:51 am
PaulStahl wrote:
Fri Apr 12, 2019 3:54 am
Jeff wrote:
Thu Apr 11, 2019 11:24 pm
I think that nothing was recorded for some reasons. But this can be also a FAT compatibility issue.
Can you send me the modified hfe to hxc2001 @ hxc2001.com ?
Ok thank you, i sent a file that was formatted with the QX3 and should have a short song on it but i think does not ..
just sent back something to test by email.
I have sent the 2 test files.. the hfe file is like before i must format then i can read and write but will lose data when i power off.. The img file i could not format or write to..

Jeff
Site Admin
Posts: 6691
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Yamaha QX3 and the Gotek USB

Post by Jeff » Sat Apr 13, 2019 7:37 am

PaulStahl wrote:
Sat Apr 13, 2019 3:32 am
Jeff wrote:
Fri Apr 12, 2019 10:51 am
PaulStahl wrote:
Fri Apr 12, 2019 3:54 am


Ok thank you, i sent a file that was formatted with the QX3 and should have a short song on it but i think does not ..
just sent back something to test by email.
I have sent the 2 test files.. the hfe file is like before i must format then i can read and write but will lose data when i power off.. The img file i could not format or write to..
Yesterday i sent you a new firmware with an IMG file to test . Have you received it ? I will send you the email again...

PaulStahl
Posts: 33
Joined: Sun Mar 03, 2019 11:16 pm

Re: Yamaha QX3 and the Gotek USB

Post by PaulStahl » Sat Apr 13, 2019 4:38 pm

Jeff wrote:
Sat Apr 13, 2019 7:37 am
PaulStahl wrote:
Sat Apr 13, 2019 3:32 am
Jeff wrote:
Fri Apr 12, 2019 10:51 am


just sent back something to test by email.
I have sent the 2 test files.. the hfe file is like before i must format then i can read and write but will lose data when i power off.. The img file i could not format or write to..
Yesterday i sent you a new firmware with an IMG file to test . Have you received it ? I will send you the email again...
I recieved 2 emails .. one contained UPD firmware and the other email contained IMG and HFE... I updated firmware with this UPD and tried to read/write the IMG and HFE ..but as i have said the HFE was the same, lose data when power down and the IMG will not work..
Also I tried to push both buttons to go through menu and see which version but the Ldr will appear for a few seconds then a flashing 4 appears

Jeff
Site Admin
Posts: 6691
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Yamaha QX3 and the Gotek USB

Post by Jeff » Sat Apr 13, 2019 8:04 pm

PaulStahl wrote:
Sat Apr 13, 2019 4:38 pm
Ldr will appear for a few seconds then a flashing 4 appears
>Error 4 : (blink 4 time and 2 seconds pause cycle) UPD File not found!

So your firmware is not updated. Have you copied the the upd file to the stick ? if so, please try another one.

In the same email you have an img file to test with this firmware.

PaulStahl
Posts: 33
Joined: Sun Mar 03, 2019 11:16 pm

Re: Yamaha QX3 and the Gotek USB

Post by PaulStahl » Sun Apr 14, 2019 5:03 am

Jeff wrote:
Sat Apr 13, 2019 8:04 pm
PaulStahl wrote:
Sat Apr 13, 2019 4:38 pm
Ldr will appear for a few seconds then a flashing 4 appears
>Error 4 : (blink 4 time and 2 seconds pause cycle) UPD File not found!

So your firmware is not updated. Have you copied the the upd file to the stick ? if so, please try another one.

In the same email you have an img file to test with this firmware.
This is my fault i did not remove usb before pressing both buttons..i can access the menu and the firmware version is 3.1.47.1 is this the correct one you sent? i have forwarded the 2 emails you sent to me with files from this post to verify...thank you

Jeff
Site Admin
Posts: 6691
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Yamaha QX3 and the Gotek USB

Post by Jeff » Sun Apr 14, 2019 9:39 am

PaulStahl wrote:
Sun Apr 14, 2019 5:03 am
This is my fault i did not remove usb before pressing both buttons..i can access the menu and the firmware version is 3.1.47.1 is this the correct one you sent? i have forwarded the 2 emails you sent to me with files from this post to verify...thank you
No. You should have the 3.1.48.1. I have just resent the email again with the img and the upd to use.

PaulStahl
Posts: 33
Joined: Sun Mar 03, 2019 11:16 pm

Re: Yamaha QX3 and the Gotek USB

Post by PaulStahl » Wed Apr 17, 2019 4:04 am

Jeff wrote:
Sun Apr 14, 2019 9:39 am
PaulStahl wrote:
Sun Apr 14, 2019 5:03 am
This is my fault i did not remove usb before pressing both buttons..i can access the menu and the firmware version is 3.1.47.1 is this the correct one you sent? i have forwarded the 2 emails you sent to me with files from this post to verify...thank you
No. You should have the 3.1.48.1. I have just resent the email again with the img and the upd to use.
The new firmware finally came through, thank you.. It now shows 3.1.48.1 and i used the img file..i had to first format it then i saved a song to it and it saved but as usual when i powered off the data disappeared .. I read something about an unusual pinout on another post but looking at both the kawai 80 and the qx3 the pinouts are the same and my kawai works .. Thanks again for your efforts, i will send
a copy of the img file that i formatted and saved to.

Jeff
Site Admin
Posts: 6691
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Yamaha QX3 and the Gotek USB

Post by Jeff » Wed Apr 17, 2019 10:50 am

Are you sure that you have used the right img file (the one present in the test.zip) or that you have sent me back the right img ?
I ask this because the content was changed (another file present).
Have you managed to read the file present on my img file before formatting it ?

PaulStahl
Posts: 33
Joined: Sun Mar 03, 2019 11:16 pm

Re: Yamaha QX3 and the Gotek USB

Post by PaulStahl » Wed Apr 17, 2019 3:49 pm

Jeff wrote:
Wed Apr 17, 2019 10:50 am
Are you sure that you have used the right img file (the one present in the test.zip) or that you have sent me back the right img ?
I ask this because the content was changed (another file present).
Have you managed to read the file present on my img file before formatting it ?
I am sure. I can not see a file present on the IMG file before formatting it.. The QX3 says 000K free 000K used.. i must format first and then it will say 713K free.. i did this and recorded a song and saved it to the formatted IMG file and sent it to you.. Of course when i turn off the QX3 i lose all data and must start over

Post Reply