Ensoniq ASR-10 and TS-10

HxC Floppy Emulator Ensoniq Keyboards/Samplers support
Western
Posts: 37
Joined: Sat Feb 05, 2011 9:17 pm

Re: Ensoniq ASR-10 and TS-10

Post by Western » Mon May 09, 2011 10:16 am

Files send. Details in e-mail.

David
Posts: 6
Joined: Mon Jul 23, 2012 9:28 pm

Re: Ensoniq ASR-10 and TS-10

Post by David » Mon Jul 23, 2012 9:55 pm

Hello, how is this progressing?
Ive just got a TS10 and although I first saw the chinese USBs floppy replacements (that I suspect wont work) yours seemed a lot more researched for my needs, as well as programmable and supported.

Am I correct in thinking it works fine when reading images but cant write just yet?
Or has that been fixed?

In any case, when theres a working solution Ill gladly buy your product!

Jeff
Site Admin
Posts: 5631
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Ensoniq ASR-10 and TS-10

Post by Jeff » Mon Jul 23, 2012 10:22 pm

David wrote:Hello, how is this progressing?
Ive just got a TS10 and although I first saw the chinese USBs floppy replacements (that I suspect wont work) yours seemed a lot more researched for my needs, as well as programmable and supported.

Am I correct in thinking it works fine when reading images but cant write just yet?
Or has that been fixed?

In any case, when theres a working solution Ill gladly buy your product!
Hi,

This is fixed (Read & Write).

David
Posts: 6
Joined: Mon Jul 23, 2012 9:28 pm

Re: Ensoniq ASR-10 and TS-10

Post by David » Mon Jul 23, 2012 10:35 pm

So for the TS10 the working settings would be IBM 720k, side based, 500kb/s, skew 3 and interleave 0?
Im interested in the USB version, I suppose both the larger PCB and the 3.5 boxed one uses the same program?
The E-Bay auction says read only for the USB version?
Which program is the right one to download after the write was fixed?

And thank you for your prompt reply!

Jeff
Site Admin
Posts: 5631
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Ensoniq ASR-10 and TS-10

Post by Jeff » Tue Jul 24, 2012 6:36 am

David wrote:So for the TS10 the working settings would be IBM 720k, side based, 500kb/s, skew 3 and interleave 0?
Im interested in the USB version, I suppose both the larger PCB and the 3.5 boxed one uses the same program?
The E-Bay auction says read only for the USB version?
Which program is the right one to download after the write was fixed?

And thank you for your prompt reply!
Why the usb version ? it's read only.
take a sd version.

For the download :
http://hxc2001.free.fr/floppy_drive_emu ... l#download

David
Posts: 6
Joined: Mon Jul 23, 2012 9:28 pm

Re: Ensoniq ASR-10 and TS-10

Post by David » Tue Jul 24, 2012 10:48 am

Well, there was no Rev F left on E-Bay so I figuered they were in production stage again.
Gives me time to save cash though, not saying its a horrible price, but I got the TS10 for just 100 EU so the upgrade will double my expences on it :lol:

When will they be for sale again?

Jeff
Site Admin
Posts: 5631
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Ensoniq ASR-10 and TS-10

Post by Jeff » Sat Jul 28, 2012 7:34 am

David wrote:Well, there was no Rev F left on E-Bay so I figuered they were in production stage again.
Gives me time to save cash though, not saying its a horrible price, but I got the TS10 for just 100 EU so the upgrade will double my expences on it :lol:

When will they be for sale again?
Right now. Just follow the links ;)

David
Posts: 6
Joined: Mon Jul 23, 2012 9:28 pm

Re: Ensoniq ASR-10 and TS-10

Post by David » Sat Nov 17, 2012 11:45 pm

Hello, I bought the Rev F finally, installed it, but I need the complete settings for formating a TS10 disk.

I used the new Beta software and followed the discussion here.
Settings: IBM MFM, 80 Tracks, 20 Sectors, 512 bytes, 2 sides, 300 RPM, Side Based, skew 3, interleave 0, 500000 bitrate.
I loaded a .img file into that, but my TS10 tells me disk is not formated.

Formating the img does not work resulting in disk not formated.
Creating a blank with the software and trying to format it creates disk drive error.

the image is of an ensoniq demo song floppy so should be correct.

Ive tried default, 720 and 1.44 modes in config.

The hfe files are also 5mb size, so I assume Im doing something very wrong.

Jeff
Site Admin
Posts: 5631
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Ensoniq ASR-10 and TS-10

Post by Jeff » Sun Nov 18, 2012 9:42 pm


David
Posts: 6
Joined: Mon Jul 23, 2012 9:28 pm

Re: Ensoniq ASR-10 and TS-10

Post by David » Sun Nov 18, 2012 10:43 pm

Thank you that worked nicely, ill just copy those a couple hundred times for my own use.
Will put out a video of everything working, however Id like to include how to extract files from ensoniq CD images and creating new floppy images, so I might wait until Ive got that working (another program) as well so TS10 users searching for upgrades can be sure that all their need can be filled with the HxC and a few PC programs :)

David
Posts: 6
Joined: Mon Jul 23, 2012 9:28 pm

Re: Ensoniq ASR-10 and TS-10

Post by David » Thu Nov 29, 2012 1:53 am

Just a small problem.
Ive got almost everything working now, but after extracting ensoniq files from various sources Ive stumbled on creating an image.
Ive installed the vfd as recommended and it seems to work fine.
However the image file size of the ts10 image when loading is causing errors.
Its says its to small for 1.68 and to big for 1.44
Im assuming there is some easy fix like forcing it anyway?
If not could you adjust the TS10 Image?

Western
Posts: 37
Joined: Sat Feb 05, 2011 9:17 pm

Re: Ensoniq ASR-10 and TS-10

Post by Western » Thu Jan 03, 2013 9:33 pm

I told about my experience using SDCard HxC Floppy Emulator with new 2 GbTranscend SD card and Ensoniq TS-10 synthesizer in "Showroom" topic.
As I stated, overall all works properly. But there are some issues. After connecting Floppy Emulator to TS-10 I found that both LEDs – Floppy and SD card access light even in operational mode, when there is NO ANY ACCESS to Floppy.
I connected oscilloscope and found that there are pairs of short low level pulses (15 uSec + 2 uSec with pause 15 uSec) on the “Select” line (pin 10). These pairs of pulses repeats with period 1 msec all the time. Signal "Motor On" (pin 16) is inactive (high level). So own TS-10’s FDD is fully inactive in operational mode. The only effect is that FDD access LED slightly lights all the time (it’s helps to musician to work in the darkness). In “Load”, “Save” or “Format” mode the both lines “Select” and "Motor On" are LOW for a long time, so FDD works properly.
(Compared to the ASR-10 its operating system does not have such behavior.)

Due to the fact that Floppy Emulator doesn’t use "Motor On" but only “Select” signal, it reacts not only for real “Load”, “Save” or “Format” LOW level signals on “Select ”line, but for these short “Select” pulses in operational mode too. So access LEDs and screen lights and flashes randomly all the time. It’s not convenient. Moreover, after one month of using the same file load from SD (Read only!) on boot up - this file, seems, crashed! Floppy Emulator became show message “FAT reading” with beeping each second. The only way to cancel this – it’s to choose another file. By the way, I wrote this file to SD once more with another name – it loads normally now. (One strange fact: PC USB card reader reads all files normally – may be due to different SD card access mode).
IMHO, SD card degradation occurs due to permanent access to one cluster.
Maybe it's necessary to prevent unintended access to SD card

Jeff, what do you think about this?

Overall, the project HxC Floppy Emulator - it's fantastic!

Next time I’ll tell about my hardware modification for connecting both FE and FDD.

Jeff
Site Admin
Posts: 5631
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Ensoniq ASR-10 and TS-10

Post by Jeff » Thu Jan 03, 2013 10:22 pm

mhh no i don't think that's the cause. Can you try this ? : replace the HXCSDFE.CFG by a new one.
Don't touch others files and reselect the problematic HFE file.

These error are generally generated by a corrupted cfg file. This can happen with a "power failure" when the cfg file is updated.
They may have sdcard failure, but this unlikely to happen with a constant read.

Also : What is your firmware version?

Western
Posts: 37
Joined: Sat Feb 05, 2011 9:17 pm

Re: Ensoniq ASR-10 and TS-10

Post by Western » Fri Jan 04, 2013 5:34 pm

First I have done I replaced the HXCSDFE.CFG by a new one – result was the same – when the problematic image file chosen, “reading FAT “ message appears and beeps each second.
I forgot to say that now, after corruption, the first file from this image that I loaded to TS-10 every time on boot up (“Grand Piano”) still loads normally, but the next file (“Revelation”) became inaccessible (message “disk not formatted” appears on TS-10 when try to load it). Although, before corruption this file loaded normally.
As I already stated, I used one file on boot up my TS-10. After loading “Grand Piano” file the track counter stops at 77 side 0. Before the file was corrupted, I noticed that track counter periodically jumps from 77 to 2 and backward all the time (without any access to disk). The file that is corrupt ("Revelation") begins just after the first one - on 77-78 tracks .
I’m not sure that there is no active LOW on “Write” line when unintended access to Floppy Emulator occurred (when “Motor ON” is passive). So unintended writes to SD are possible!

My Firmware version is 1.6.0.0

Jeff
Site Admin
Posts: 5631
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Ensoniq ASR-10 and TS-10

Post by Jeff » Fri Jan 04, 2013 8:31 pm

Western wrote: My Firmware version is 1.6.0.0
This firmware is almost two year old.
Please update to the last one, lot of Sdcard stuff have been corrected since the v1.6.0.0.

Also : Can you check the 5V power supply ? What is its value ?
When did you buy you board ?

Post Reply