Problem creating working .EII sound bank files.

HxC Floppy Emulator E-mu Emulator I & II support
Post Reply
Egg
Posts: 8
Joined: Tue Nov 08, 2011 7:13 pm

Problem creating working .EII sound bank files.

Post by Egg » Wed Nov 09, 2011 2:45 am

Can you tell me the exact procedure to merge the E2 OS file with the .EII sound bank files?

I took a single .EII file and converted it to .hfe using the default settings.

I then took the 3.1 OS file from the EXMP website and also converted it to .hfe.

I then put both files in one folder and put it on the SD card.

But the E2 will only load up the OS separately, it wont load the sound bank.

Jeff
Site Admin
Posts: 6303
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Problem creating working .EII sound bank files.

Post by Jeff » Wed Nov 09, 2011 9:57 am

Egg wrote:Can you tell me the exact procedure to merge the E2 OS file with the .EII sound bank files?

I took a single .EII file and converted it to .hfe using the default settings.

I then took the 3.1 OS file from the EXMP website and also converted it to .hfe.

I then put both files in one folder and put it on the SD card.

But the E2 will only load up the OS separately, it wont load the sound bank.

Just rename your OS file image to emuiios.emuiifd, put it in your *.EII folder, and convert them with the HxC software.
emuiios.emuiifd and *.EII file will be merged together.

Egg
Posts: 8
Joined: Tue Nov 08, 2011 7:13 pm

Re: Problem creating working .EII sound bank files.

Post by Egg » Wed Nov 09, 2011 1:14 pm

Jeff wrote:
Egg wrote:Can you tell me the exact procedure to merge the E2 OS file with the .EII sound bank files?

I took a single .EII file and converted it to .hfe using the default settings.

I then took the 3.1 OS file from the EXMP website and also converted it to .hfe.

I then put both files in one folder and put it on the SD card.

But the E2 will only load up the OS separately, it wont load the sound bank.

Just rename your OS file image to emuiios.emuiifd, put it in your *.EII folder, and convert them with the HxC software.
emuiios.emuiifd and *.EII file will be merged together.
Thanks Jeff, I have just done exactly that and it has made two files; emuiios_emuiifd.hfe and the sound bank .hfe. I guess I expected to see one file if it was merging the two together.

Anyway I will test it on the E2 when I get home in a little while.

Jeff
Site Admin
Posts: 6303
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Problem creating working .EII sound bank files.

Post by Jeff » Wed Nov 09, 2011 2:07 pm

Egg wrote:
Jeff wrote:
Egg wrote:Can you tell me the exact procedure to merge the E2 OS file with the .EII sound bank files?

I took a single .EII file and converted it to .hfe using the default settings.

I then took the 3.1 OS file from the EXMP website and also converted it to .hfe.

I then put both files in one folder and put it on the SD card.

But the E2 will only load up the OS separately, it wont load the sound bank.

Just rename your OS file image to emuiios.emuiifd, put it in your *.EII folder, and convert them with the HxC software.
emuiios.emuiifd and *.EII file will be merged together.
Thanks Jeff, I have just done exactly that and it has made two files; emuiios_emuiifd.hfe and the sound bank .hfe. I guess I expected to see one file if it was merging the two together.

Anyway I will test it on the E2 when I get home in a little while.
if you have done a "batch convert" this only a side effect. just use the hfe sound bank.

Egg
Posts: 8
Joined: Tue Nov 08, 2011 7:13 pm

Re: Problem creating working .EII sound bank files.

Post by Egg » Wed Nov 09, 2011 3:33 pm

Ok tested.

It works but with an initial error:

Switch E2 on, it displays "Insert Diskette". Choose file on HxC, selecting soundbank.hfe. E2 doesn't load file, it just displays "DiskFormat Error". Click on HxC to de-select soundbank file, click back on the same file again to re-select it, loads fine and works as normal.

Is this normal, and can it be rectified?

Thanks!

Jeff
Site Admin
Posts: 6303
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Problem creating working .EII sound bank files.

Post by Jeff » Wed Nov 30, 2011 8:06 pm

Egg wrote:Ok tested.

It works but with an initial error:

Switch E2 on, it displays "Insert Diskette". Choose file on HxC, selecting soundbank.hfe. E2 doesn't load file, it just displays "DiskFormat Error". Click on HxC to de-select soundbank file, click back on the same file again to re-select it, loads fine and works as normal.

Is this normal, and can it be rectified?

Thanks!
This is a know issue. I am working on this.

jbfairlight
Posts: 41
Joined: Sun Feb 17, 2008 10:22 pm
Location: Ile de France
Contact:

Re: Problem creating working .EII sound bank files.

Post by jbfairlight » Sat Jan 14, 2012 7:08 pm

Hi Francois, do you find corrections for this bug ?

I like fix this :wink:

Jeff
Site Admin
Posts: 6303
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Problem creating working .EII sound bank files.

Post by Jeff » Sun Jan 15, 2012 12:26 pm

jbfairlight wrote:Hi Francois, do you find corrections for this bug ?

I like fix this :wink:
Sans la machine difficile de corriger cela...

Post Reply