Gotek with Emulator II - No disk

HxC Floppy Emulator E-mu Emulator I & II support
Post Reply
Sandrow
Posts: 13
Joined: Thu Feb 18, 2016 3:14 pm

Gotek with Emulator II - No disk

Post by Sandrow » Wed Jan 24, 2018 2:29 pm

Got an Emulator II with one working floppy drive and my goal is to place a Gotek hxc on upper floppy slot.

I'm far from this point, since I can't get the gotek working or able to read.hfe disks.

Here what I've done until now.

- Bought license for HXC

- Wrote firmware on it successfully (done the same on other Goteks for my Ensoniq mirage and Atari stf and they are working)

- Downloaded "HXCFEUSB_HFE_beta_firmware"

- USB stick formatted to FAT 32 (tried with several sticks)

- HXCFEUSB_HFE_V3_0_8_2a.upd place on the empty USB

-USB inserted ito Gotek

-Both button pressed and then power to the Gotek keeping them pressed for few seconds.

-Cursor started to run around the diplay segments

- After few seconds, "888" flashed three times and then "HXC" on display
I guess this should be fine.

I have placed the config file from \HXCFEUSB_HFE_beta_firmware\Config_Files\Indexed_mode\HXCSDFE.cfg

- Placed some emulator Disks with data named DSKA0001.hfe, DSKA0002.hfe and so on

Once inseerted in Gotek, display remains on "HXC" without showing the disk.

Tryout II.
Flashed the HXCFEUSB 3.1.x firmware with same steps.
It shows "NOR" regardless which kind of cfg. File is on the stick.

What should i Do?

Thanks.
Best regards,
Sandro.

Jeff
Site Admin
Posts: 6691
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Gotek with Emulator II - No disk

Post by Jeff » Wed Jan 24, 2018 4:30 pm

"NOR" = Normal mode.

You probably don't use the right config file.

Use the indexed config file.

If you are 100% sure to use the right config file and a valid DSKA0000.HFE file, try to reinit the usb stick with diskpart :

http://knowledge.seagate.com/articles/e ... Q/005929en

If this still doesn't work, try a different usb stick.

Sandrow
Posts: 13
Joined: Thu Feb 18, 2016 3:14 pm

Re: Gotek with Emulator II - No disk [SOLVED]

Post by Sandrow » Fri Jan 26, 2018 3:11 am

Solved.
Flashed again the GOTEK, it shows no more "NOR" without USB inserted.
Then placed correct .HFE images that Jeff provided me on USB now it works.

Thanks.

Post Reply