EMU II GOTEK HXC: Drive ID 1 - 2

HxC Floppy Emulator E-mu Emulator I & II support
Post Reply
Sandrow
Posts: 13
Joined: Thu Feb 18, 2016 3:14 pm

EMU II GOTEK HXC: Drive ID 1 - 2

Post by Sandrow » Fri Jan 26, 2018 5:11 am

Hi,
got an Emulator II with one working Floppy Drive.

Got a GOTEK floppy emulator and upgraded with latest firmware.
Got a copy of the Memory RAM test, converted to .HFE file with "HXC floppy emulator app"and it works.

Now, the previous owner gave me a bunch of 300 Floppies with sound banks and samples.
I'd like to copy them to the USB.

I'm using cable wiring Setup n°5 (straight connection to Floppy Drive and twisted to the Gotek port)
GOTEK is drive #1 ( jumper set to S0)
Original Floppy Drive is #2 ( jumper left as it was, and it's without the resistor array in its socket)

I can't get it working.

The Memory test disk (named DSKA0001.HFE) is actually the only one working
All other .HFE disks i've made remain stuck at "Software rev 3.1" after boot.
Tried batch converting, tried renaming the Emulator II empty disks but nope, all .HFE disks just don't load,

On other Hand, Emulator set DRIVE #2 as the copy destination drive.
I've tried to set the floppy drive as #1 by resistor array and jumper setting, but if Gotek is set to #2 ( S1) the Emulator says "No 2nd drive"

Please, help.
Last edited by Sandrow on Fri Jan 26, 2018 12:25 pm, edited 1 time in total.

Jeff
Site Admin
Posts: 5200
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: EMU II GOTEK HXC: Drive ID 1 - 2

Post by Jeff » Fri Jan 26, 2018 8:20 am

Is the EII images present into this archive working ? :

http://hxc2001.com/download/floppy_driv ... Images.zip

Sandrow
Posts: 13
Joined: Thu Feb 18, 2016 3:14 pm

Re: EMU II GOTEK HXC: Drive ID 1 - 2

Post by Sandrow » Fri Jan 26, 2018 12:17 pm

HI Jeff.

I'm using exactly these ones.
SDHxCFE_Emu_Emulator_II_zip

Unizipped, renamed into DSKA0002.HFE, DSKA0003.HFE DSKA0004.HFE.
Tried also to leave them on USB with original names, nope.

Thanks.

Jeff
Site Admin
Posts: 5200
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: EMU II GOTEK HXC: Drive ID 1 - 2

Post by Jeff » Fri Jan 26, 2018 5:57 pm

Sandrow wrote:
Fri Jan 26, 2018 12:17 pm
HI Jeff.

I'm using exactly these ones.
SDHxCFE_Emu_Emulator_II_zip

Unizipped, renamed into DSKA0002.HFE, DSKA0003.HFE DSKA0004.HFE.
Tried also to leave them on USB with original names, nope.

Thanks.
Then this is probably an hardware setting problem. is the jumper correctly set to S0 ?
Which firmware version are you using ?

Sandrow
Posts: 13
Joined: Thu Feb 18, 2016 3:14 pm

Re: EMU II GOTEK HXC: Drive ID 1 - 2

Post by Sandrow » Fri Jan 26, 2018 9:34 pm

Jeff wrote:
Fri Jan 26, 2018 5:57 pm
Then this is probably an hardware setting problem. is the jumper correctly set to S0 ?
Which firmware version are you using ?
I think so.
But i can't figure out why the Memory test disk is working flawless.

HXCFEUSB_V3_1_1_2a.UPD

Yes, Jumper is set to S0 and it's the only one on contacts row.

Sandrow
Posts: 13
Joined: Thu Feb 18, 2016 3:14 pm

Re: EMU II GOTEK HXC: Drive ID 1 - 2

Post by Sandrow » Sat Jan 27, 2018 12:53 am

.
Last edited by Sandrow on Sat Jan 27, 2018 1:00 am, edited 1 time in total.

Sandrow
Posts: 13
Joined: Thu Feb 18, 2016 3:14 pm

Re: EMU II GOTEK HXC: Drive ID 1 - 2

Post by Sandrow » Sat Jan 27, 2018 12:59 am

I have found another floppy cable, straight to the 5.25" connector and leads 10-16 twisted on 3.5".

Now Gotek reads disks, a crosstalk between two leads, maybe.

Anyway, Both drives are working if connected standalone so i guess the cable is ok.

If i set the Gotek as #1 (Jumper to S0)
and 5.25" as #2 ( no resistors on chip and Jumper to )

At startup, when Gotek starts loading, the 5.25" with its lever engaged starts making a continuous noise like whine or "motor engaged", but the disk actually doesn't spin or read at all, no move from the heads too.
The noise ends when the load from Gotek is completed.
Then, if i select "Get Bank disk 2" i have "Disk Format Error" (The floppy is of course good since it loads and works if the 5.25" drive is connected alone).


If i remove the USB stick and boot the machine i have the continuous whining noise and " Insert Diskette"
Another interesting thing:
If if boot the machine with 5.25" lever un-engaged it starts whining, but when the noise ends, if i engage the lever ( heads down to read disk) it start loading.
It will work until next load request, for example a button function that request software ( like "Disk option" or " sample").
Once again, un engage and re engage the lever and the 5.25" disk starts reading....


If i set the Gotek as Drive #2 ( jumper on S1) and the 5.25" as #1 ( resistor chip inserted and jumper to first slot) i have same results.

Headache....



Image

Image

Image

Image

Thanks.

Jeff
Site Admin
Posts: 5200
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: EMU II GOTEK HXC: Drive ID 1 - 2

Post by Jeff » Sat Jan 27, 2018 1:57 am

I see a twisted part on the ribbon. i think that this is the issue.

Sandrow
Posts: 13
Joined: Thu Feb 18, 2016 3:14 pm

Re: EMU II GOTEK HXC: Drive ID 1 - 2

Post by Sandrow » Sat Jan 27, 2018 2:23 am

yes it is.

i've followed this instruction:
Image

I thought that twisted cable were meant to be like this..

Do you mean i need a straight cable for both the connectors?

Jeff
Site Admin
Posts: 5200
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: EMU II GOTEK HXC: Drive ID 1 - 2

Post by Jeff » Sat Jan 27, 2018 2:42 am

Sandrow wrote:
Sat Jan 27, 2018 2:23 am
yes it is.

i've followed this instruction:
Image

I thought that twisted cable were meant to be like this..

Do you mean i need a straight cable for both the connectors?
yes.
Or try the MTRON /MO jumper position (this is equal to ID3A)

Sandrow
Posts: 13
Joined: Thu Feb 18, 2016 3:14 pm

Re: EMU II GOTEK HXC: Drive ID 1 - 2

Post by Sandrow » Sat Jan 27, 2018 10:45 am

I've tried the MO yesterday and can confirm that doesn't work.

I'm gonna find a new cable and I'll keep you posted.

Thanks. :)

Sandrow
Posts: 13
Joined: Thu Feb 18, 2016 3:14 pm

[SOLVED] EMU II GOTEK HXC: Drive ID 1 - 2

Post by Sandrow » Sun Jan 28, 2018 3:18 pm

Got it!
I can't tell how it could works, but i got it!

Straight cable to 5.25" Drive without twisted Drive #2 lead.
5.25" is set as "Hybrid" Drive#1, i mean with jumper set to #1 and without the mandatory resistor Chip onboard
Gotek is set as Drive #2.

Now i can read from Real floppy and save to USB !!!

Let's ride the Emulator II :)
Yeeeeeeee-hhhhhaaaawwww!!!!!
(Whip Sound)

:twisted: :twisted: :twisted:
Thanks!

Post Reply