Emax SE Writing

HxC Floppy Emulator E-mu Emax support
m-sonic
Posts: 9
Joined: Wed Aug 28, 2013 2:23 pm

Re: Emax SE Writing

Post by m-sonic » Thu Aug 29, 2013 8:52 am

I bought the emulator long time ago but had no time to install it into the Emax.
Last week I started to do some cosmetics on my equipment and installed the emu the first time. I don't know what version was installed before. Never tried the functions. I downloaded the last firmware, made the versionupdate and started from this point. So I can not verify. As you said, I will boot the hardware tonight without the cartridge to check the version.
I can't see what you mean with: format the image with the EMAX. Can I format an EML image with the EMAX itself by using the OS from EMAX (Format floppy) as a feature?
Supposable it won't work because of the write error but I'll give it a try.

thanks in advance
Mike

Jeff
Site Admin
Posts: 5748
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Emax SE Writing

Post by Jeff » Thu Aug 29, 2013 8:56 am

m-sonic wrote:Can I format an EML image with the EMAX itself by using the OS from EMAX (Format floppy) as a feature?
Supposable it won't work because of the write error but I'll give it a try.
I don't know what you call "EML", but yes with the lastest firmware you can format the HFE file exactly as a true floppy disk from the machine. i recommend you to do this to be sure that the disk have the right format.

Which image are you using ?

EDIT : what do you mean by "long time ago" ?

m-sonic
Posts: 9
Joined: Wed Aug 28, 2013 2:23 pm

Re: Emax SE Writing

Post by m-sonic » Thu Aug 29, 2013 9:33 am

I formatted with the original floppy drive a fresh DD floppy. No banks and no samples were on the disk. Only the "Untitled" preset (then emxp to create the floppy image).
Additionally I tried some copies of the original library (Z701, Z702 ...) with the same effect.

Finally the images created with the HXC Software should be fine.

Sorry, I meant the .hfe extension.

I bought the Floppy Emulator one or two years ago. It is REV C yet. Long time has passed- so I looked first for an update and found one from August this year.

regards Mike

Jeff
Site Admin
Posts: 5748
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Emax SE Writing

Post by Jeff » Thu Aug 29, 2013 12:35 pm

m-sonic wrote: I bought the Floppy Emulator one or two years ago. It is REV C yet.
Please check again the hardware revision. Do you get a "memory test failed" message at power up ?

m-sonic
Posts: 9
Joined: Wed Aug 28, 2013 2:23 pm

Re: Emax SE Writing

Post by m-sonic » Thu Aug 29, 2013 12:46 pm

No. I don't get a message like this during power up.

Jeff
Site Admin
Posts: 5748
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Emax SE Writing

Post by Jeff » Thu Aug 29, 2013 12:52 pm

In this case :
- Check the firmware version.
- Try to format an image from the emax
- Send me the HFE file in case of a write fail.

- Very Last thing to test : I will send you the old firmware version.

m-sonic
Posts: 9
Joined: Wed Aug 28, 2013 2:23 pm

Re: Emax SE Writing

Post by m-sonic » Thu Aug 29, 2013 1:03 pm

Thank you. I'll make all the things tonight when back home and give you a reply.

m-sonic
Posts: 9
Joined: Wed Aug 28, 2013 2:23 pm

Re: Emax SE Writing

Post by m-sonic » Thu Aug 29, 2013 4:58 pm

Hi Jeff,

I checked all. On the board is rev c printed. the firmware on board is the one i described above.

I can't format a floppy image. It only begins RW with block 001 and then it stops with the error.
May it has something to do with the OS Plus 1.0 from the EMAX?

regards Mike

Jeff
Site Admin
Posts: 5748
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Emax SE Writing

Post by Jeff » Thu Aug 29, 2013 7:21 pm

m-sonic wrote:Hi Jeff,

I checked all. On the board is rev c printed. the firmware on board is the one i described above.

I can't format a floppy image. It only begins RW with block 001 and then it stops with the error.
May it has something to do with the OS Plus 1.0 from the EMAX?

regards Mike
Don't know. (Is it the right OS for this emax ?)

Send me some HFE : After the format and after some write attempt :
I will send to you back the old firmware to test.

Please send me a picture of the jumper setting of the hxc too.


http://hxc2001.free.fr/imiel.htm

m-sonic
Posts: 9
Joined: Wed Aug 28, 2013 2:23 pm

Re: Emax SE Writing

Post by m-sonic » Thu Aug 29, 2013 8:33 pm

I send you the file from my mailbox. The limit is reached using the forum. It countains two files. One is the original created by HXC Software. The other is the corrupted one after formatting with the emu. The OS is now not bootable anymore. The bank is readable and could be loaded. When I would save the bank to the hfe floppy image it will be unreadable too.

hope that helps

regards Mike

Jeff
Site Admin
Posts: 5748
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Emax SE Writing

Post by Jeff » Fri Aug 30, 2013 7:31 am

Thanks. New firmware (1.8.2.30b) to test in your email box.

m-sonic
Posts: 9
Joined: Wed Aug 28, 2013 2:23 pm

Re: Emax SE Writing

Post by m-sonic » Fri Aug 30, 2013 7:43 pm

get a "data lost" error using this firmware. all sectors will be read but writing seems to be the problem. tried different sdcards with different capacities.

regards mike

Jeff
Site Admin
Posts: 5748
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Emax SE Writing

Post by Jeff » Fri Aug 30, 2013 9:33 pm

m-sonic wrote:get a "data lost" error using this firmware. all sectors will be read but writing seems to be the problem. tried different sdcards with different capacities.

regards mike
and what about the version v1.8.2.31a ?
Please send me the HFE file after the write test.

(EDIT: ANd try the old 1.7.2.0 version too).

Post Reply