Emax 1 problem

HxC Floppy Emulator E-mu Emax support
Post Reply
Lostatom
Posts: 12
Joined: Wed Jun 27, 2018 9:37 pm

Emax 1 problem

Post by Lostatom » Wed Jun 27, 2018 9:53 pm

Hello,

I just got an Emax 1 and installed a Gotek Hxc usb drive instead of the floppy drive.

I can create a bootable usb stick using EMXP and get the machine started. But, I can't get the the librarys to work. I have downloaded and tried the original EMax librarys, the Alan Wilder library and a few others. When I copy them to an hxc image on the usb stick via EMXP I may get one of the presets to work on the sampler. But most of the time it just shows preset 00. I have tried a lot of times and sometimes a single bank will work and other times no banks work. I can see all the banks and the OS on the usb key in Windows, so they do get copied to the disk.

I have read the EMXP manual og gathered as much info as I can from forums etc. but I am stuck.


Any help would be appreciated

Thanks

Jeff
Site Admin
Posts: 6301
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Emax 1 problem

Post by Jeff » Wed Jun 27, 2018 11:29 pm

Are you using the indexed mode ? If so you need to rename the files images to DSKA0000.XXX , DSKA0001.XXX, DSKA0002.XXX...
(replace XXX by the file extension) and use the index config file.

Lostatom
Posts: 12
Joined: Wed Jun 27, 2018 9:37 pm

Re: Emax 1 problem

Post by Lostatom » Thu Jun 28, 2018 6:18 am

I'm not shure I know exactly what indexed mode is. But I just tried to rename the files when copying in EMXP. I just copyied a few banks to see if it would work and it did. Somewhat anyway. It was able to read the first bank - the grand piano but then it just jumps from preset 25 to 99 with nothing in between.

Forgive me for being a complete newbie, but I am still a litlle confused about the file handling etc.

Jeff
Site Admin
Posts: 6301
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Emax 1 problem

Post by Jeff » Thu Jun 28, 2018 8:09 am

Lostatom wrote:
Thu Jun 28, 2018 6:18 am
I'm not shure I know exactly what indexed mode is. But I just tried to rename the files when copying in EMXP. I just copyied a few banks to see if it would work and it did. Somewhat anyway. It was able to read the first bank - the grand piano but then it just jumps from preset 25 to 99 with nothing in between.

Forgive me for being a complete newbie, but I am still a litlle confused about the file handling etc.
Here it is :
Indexed mode

In this mode the file images must be named DSKA0000.HFE, DSKA0001.HFE, DSKA0002.HFE,...
The 2/3 digits display shows the actual file number selected.

No LCD and/or extra push button is needed to use this mode.
No extra software needed.

This is the recommended mode when you don't have the extra LCD & button and when
your machine can't use the autoboot mode (see below).

The config file to copy to the root of the flash media for this mode :

Config_Files/Indexed_mode/HXCSDFE.CFG from the USB Stick STM32 HxC Floppy Emulator firmware update archive

Lostatom
Posts: 12
Joined: Wed Jun 27, 2018 9:37 pm

Re: Emax 1 problem

Post by Lostatom » Thu Jun 28, 2018 4:20 pm

Thanks,

I copied the config file to the root of the usb and the Emax display says Insert Disk and the Gotek display switches between 000 and err. The Emax os is ver. 3.2.

Lostatom
Posts: 12
Joined: Wed Jun 27, 2018 9:37 pm

Re: Emax 1 problem

Post by Lostatom » Thu Jun 28, 2018 4:27 pm

I think I got i working now. I was copying the config file and the librarys to a usb that I already formatted as a bootable os disk. Once I removed that and just made a disk with the config file and the librarys it seems to work.

Thanks

Lostatom
Posts: 12
Joined: Wed Jun 27, 2018 9:37 pm

Re: Emax 1 problem

Post by Lostatom » Thu Jun 28, 2018 7:10 pm

Ok, I thought I had it made.. I can get the librarys to play after renaming to DSKA... and copying the config file to the root of the usb stick. But if I try to enter analog processing or any other module on the Emax1 it says Different software rev!


Any ideas??


thanks


p

Jeff wrote:
Thu Jun 28, 2018 8:09 am
Lostatom wrote:
Thu Jun 28, 2018 6:18 am
I'm not shure I know exactly what indexed mode is. But I just tried to rename the files when copying in EMXP. I just copyied a few banks to see if it would work and it did. Somewhat anyway. It was able to read the first bank - the grand piano but then it just jumps from preset 25 to 99 with nothing in between.

Forgive me for being a complete newbie, but I am still a litlle confused about the file handling etc.
Here it is :
Indexed mode

In this mode the file images must be named DSKA0000.HFE, DSKA0001.HFE, DSKA0002.HFE,...
The 2/3 digits display shows the actual file number selected.

No LCD and/or extra push button is needed to use this mode.
No extra software needed.

This is the recommended mode when you don't have the extra LCD & button and when
your machine can't use the autoboot mode (see below).

The config file to copy to the root of the flash media for this mode :

Config_Files/Indexed_mode/HXCSDFE.CFG from the USB Stick STM32 HxC Floppy Emulator firmware update archive

Jeff
Site Admin
Posts: 6301
Joined: Fri Oct 20, 2006 12:12 am
Location: Paris
Contact:

Re: Emax 1 problem

Post by Jeff » Mon Jul 02, 2018 8:09 am

yes : the emax.emx file used to convert the images isn't matching with your OS EPROM. You need to reconvert the EM1 images with the right os file...

Lostatom
Posts: 12
Joined: Wed Jun 27, 2018 9:37 pm

Re: Emax 1 problem

Post by Lostatom » Mon Jul 02, 2018 9:02 pm

Thanks so much for the help. It works now.

Is there a way to get emax to read more than 99 banks from a usb?


thanks again.

p

Lostatom
Posts: 12
Joined: Wed Jun 27, 2018 9:37 pm

Re: Emax 1 problem

Post by Lostatom » Wed Jul 04, 2018 12:30 am

My bad, this isn’t an issue at all.

Thanks

P

Post Reply